• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Annoying Samsung Galaxy S Plus wake me up every night at fully charged, hmm

peter12345

Lurker
Apr 19, 2012
8
0
Hi all
smile.gif
nice to join a big android forum.

Iif you have a Samsung Galaxy S Plus phone, you must prepare yourself for a nightmare where you every night will be awakened by the phone as happens when the phone is in the charger and get it charged to 100%. The phone will vibrate and if you're the type who sleeps lightly, you can prepare yourself to be woken up every night. I try to google and read a lot of newsgroups and has unsuccessfully trying 4-5 different battery Charged silencer apps, including the app called "Battery Charged silencer." It is so frustrating and I seriously consider selling my new phone and buy another instead. It's completely crazy to buy a phone for 400 to 500 USD which then wake me up every night and warning me that the charge is done :mad:. If you set the phone to fully silent then perhaps it doesn't notify at fully charge but it is not an option for me because my phone MUST also work at night. Other solutions like putting it in another room is not an option because I MUST be able to receive important calls at night and sometimes also use the alarm to wake me up in the morning. Charge a day is too unconvenient and not a possibility.

I really really hope someone here can help with a link to a root trick or something which can turn off the vibrate notification at full charge or turn off the vibrator completely because i really don't need that vibrator for anything.

Thanks
 
One option would be to leave your phone at the foot of your bed rather than the head. Hopefully it won't disturb your sleep when it goes off on a full charge.

Other option is to try Tasker. It's $6, but it's really robust and offers a lot of automation/customization. I disabled my full charge notifications (bright screen, vibrate, sound) with it on my GNote. Great app. I'm still trying to work with it as it's quite a bit of learning involved. Hopefully get some of the apps/data connections automated instead of manually doing it (and forgetting about it sometimes).
 
Upvote 0
Try:
Phone->Menu->Setting->Sound->Vibrate->Off
Phone->Menu->Setting->Sound->Notification ringtone->Silent
Sure that's great, but what if he gets a phone call in the middle of the night that he needs to answer?

I'm really tired of manufacturers doing this kind of ridiculous stuff. It goes into the same category of a TV having a bright LED ON when the TV is OFF or a cordless phone that has a bright blue charging light, etc. I must have 5 devices in my house with electrical tape over LEDs.
 
Upvote 0
I already tried the settings (vibrate off etc) as you say without any luck. It stills vibrate but there is no notification sound from the speaker.

But now some good news. I found out that it only vibrates when the phone is in "silent mode" (see Phone->Menu->Setting->Sound) and when it is in normal mode there is no vibration lol -- weird but that's the way it is. Soo my solution is at night while charging to have the phone in normal mode but without notification/sms sounds - then i can only hear if someone is calling. If i at night only want to hear call from certain people i could download a kind of filterprogram (haven't tried that yet).

Currently i'm using an app "my profiles" to filter people but that program set the phone to "silent mode" and that's why my phone is vibrating at full charge. Soo now i change "my profiles" to another much more simple filter program to only allow certain people call me at night :). I think i keep my samsung - lol
 
Upvote 0
hello i tested tasker from Crafty Apps. First time the battery was fully charged it worked but now it doesn't work again, hmmm.

That's interesting, I've tested it 3-4 times while I was fully awake and my full charge is completely silent, no vibration and display off. I also have Vibrate set to Always in my Sound Settings. Maybe something within the tasker profile is not properly set? I know it took me a while experimenting with things to get the proper settings to work the way I wanted it to.

But Tasker can be a bit overwhelming with so many options to sift through and having the patience to learn and figure things out.

Have you tried Profile Scheduler? It has an option to turn vibrate notifications off and white list function. Which is what I think you're looking for?

HTH.
 
Upvote 0
I have a galaxy S3 as well and had the same problems with vibrating when fully charged and it waking me up.
I found how to fix it though:
-Go to Settings.
-Go to Sound.
-Turn off Haptic Feedback option.
-Turn off AutoHaptic.
-Go to Vibration Intensity (also under sound menu.)
- Move the Haptic Feedback intensity all the way down (to the left).

Your phone will still ring or vibrate for calls or notifications if you have it set to do that normally. This will only turn off the vibration during charging. And unfortunately will turn off vibration during games too. Small price to pay for sleep though.

The screen will still light up however, not sure how to fix that one yet, Just keep your phone face down so the light won't wake you for now.

Sleep tight!
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones