• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Can connect to wi-fi but only some sites/apps will work


Jul 4, 2013
I'm not able to use the Internet through my Linksys WRT54G v6.0 router on my Nexus 7, running Android 4.2.2. Before Sunday everything was working fine with it. Now, only a few things on the tablet are able to use the Internet -- everything else times out and gives an error when I try to load something. I don't immediately get an error when I try to access or update a page or app. It hangs for about 10 seconds, and then tells me that it can't load.

What does work:
-I can search Google using the built-in Google search app.
-A few sites will load in Chrome (it seems like the sites that I don't visit will load. This makes me think it's a caching issue, see below)

What doesn't work:
In particular,
-Facebook app
-Pandora app
-Pretty much any other app that requires the Internet.

What I tried:
-At first, I thought it might be a DNS issue. So, I downloaded SetDNS from Google Play and changed my DNS (I was then using Google DNS 8.8.*) to OpenDNS. This didn't fix the problem.
-I then thought it might be a caching issue, but thought it was odd that Google searching in the dedicated app (not sure what this is called) would still work since I still use that regularly. So I tried removing local data and cache in the Facebook app, but this did not fix the problem in the app. I also tried the same method for Chrome by removing the local app data and cache, and still no luck.
-Hard resets of my modem and router.
-Hard reboot of the Nexus 7.
-Forget the Wi-Fi connection, and re-connect. Still the same behavior.
-I checked if my router (Linksys WRT54G) or modem (Actiontec M1000) have any firmware updates available, and they don't.
-Other Wi-Fi networks will work just fine.
-Other computers can connect to and use the Wi-Fi (and wired) connections that I'm having trouble with my Nexus on.
Rather than use an app to set DNS

Where did he say he used an app to change DNS? But in any case I can't add to the list of things already tried, that's exactly what I'd have done too.

There have been the occasional post indicating similar symptoms - a Nexus 7 refusing to work properly with some router that other devices had no issue with and working perfectly with others. No rational explanation has been forthcoming so far (or if it has I missed it!) and I can't find the thread anyway :-(

It's probably worth trying turning off the power saving thingy in the advanced settings - "Wifi optimization" I think it's called. My N7 was eating battery when connected to my BT Home Hub because of some incompatibility that vanished when I turned the setting off. Different problem I know, but there may be some incompatibility issue that's causing your symptoms and it does no harm to try it and see.
Upvote 0
You've looked to have tried everything I'd normally suggest.

Rather than use an app to set DNS, have you tried configuring it manually? Settings -> WiFi -> Long Press the connection name -> Modify Network -> Advanced -> IP Settings -> Static (you'll need to enter your connection info manually).

This fixed the problem! I changed the IP address to something that was much higher in the subnet than what was being used by the other computers on the network (eg., the DHCP IP range was, so I gave it for its address).

I checked my modem's Port Forwarding settings, and I noticed that a lot of the rules were defined for the IP address that the tablet had. One of those rules was for port 80 (HTTP), so I'm guessing that was what was causing the problem. My DHCP configuration must have changed. I haven't tested this theory yet.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.