• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Can't get into Recovery, Battery doesn't seem to charge, stuck at first flash screen. Please help


Dec 29, 2011
I decided to take the plunge into rooting my phone. I wanted better battery life. So i decided to follow this video:
How to Root the Samsung Galaxy S II Epic 4G Touch - Latest - YouTube

He is using the exact same modem as me, so i figured it wouldn't be hard to do. So I got passed this video and everything seemed good. So I installed titanium. I then proceeded to remove sprint apps like the nascar, zone, radio, media etc. I kept the sprint ID as I didn't know how important that would be. Anyways everything still good.

Then I went ahead and followed his next video:
How to Install Clockworkmod on the Samsung Epic 4G Touch - Latest - YouTube. But it failed on the last part when moving the cwm files. So I deleted some music off my phone to make room. But I had to hit enter and the program rebooted my phone. It took a little longer, as was expected by the warning it gave and that it was normal. But everything was ok. But since it said failed when I did it, I decided to do it again. This time it copied successful. Great!!!! hit enter so it can reboot, and now my phone is stuck on the Samsung Galaxy S II first screen.

So I figured I can still get into recovery, but I can't. I hold the volume up button (and tried with both volume up and down held) and the power button. But what is weird and fustrating is that when i pull out the battery, and put it back in the phone turns on itself. (reminds me of pandora's battery for the psp, but thats another story). Anyways, i also tried plugging in the usb, but that will bring up the greyed out battery icon with the loading wheel, but the wheel is frozen too. Usually it spins then shows me that its charging after some time. But I get nothing. So, I restart to try to get in recovery, (even holding the buttons down before I put the battery in), but still the darn thing turns on by itself, and does not do anything after first screen. Can anyone help.

I tried researching this, but everyone seems to be able to get to their recovery window, and I can not.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.