• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Captivate not connecting to Mac (USB)


May 17, 2011
Running the risk of duplicate threads. Sorry, but I can't find a solution anywhere.

I can't connect the phone to my Mac via USB. I have read a lot of threads everywhere on the internet and tried the following, though nothing works:

- USB set to Mass Storage, USB debugging ON
- USB set to Mass Storage, USB debugging OFF
- USB set to always ask, USB debugging ON/OFF
- USB set to Media Player, USB debugging ON/OFF
- Tried getting Kies, but it looks like it doesn't exist for Macs.

The phone recognizes that it's connected to the machine, whereas the machine doesn't respond at all (nothing shows up in the /dev folder as well). I tried connecting it on a friend's Windows 7 machine after installing the Samsung drivers, still nothing. So the issue is at the phone side, I believe.

Is there any fix on the phone side for this? The USB cable cannot be bad as the phone still recognizes the connection.

[I just got it from a guy who had unlocked it and put Phoenix Unleashed (based on the JS8 ROM, Android 2.2.1) on it. Before handing it over, he had factory reset the phone. It has a 16G internal SD card.]

Any help whatsoever appreciated.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.