• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [CDMA] Evo 3D - phone won't ring when screen off

graham722

Lurker
Apr 24, 2011
6
0
Hi all -

Looks like I need some help. Basically, my EVO 3d has stopped ringing when the screen is off. This has been going on for weeks. It doesn't ring, and I don't get a missed call notification. It just goes to voicemail. If the screen is on, it rings.

I have tried all the settings.

I am rooted. S-OFF. Currently running MeanRomICS 2.2 and I really like it. But.. I do need my phone to actually work as a phone.

The last time everything was working, I was running Infected Eternity ROM 3.01. At that time, I flashed the latest radios. First I flashed 0.97.10.0808 because it contained the latest Wifi update, then I flashed 1.06.00.1216. And everything worked. I did seem to think that I wasn't getting any noticeably better performance, but the problem I describe had not surfaced.

I wanted to try an ICS ROM so I flashed Chubbz Booster Shot RC2 ROM. It seems like my phone stopped ringing at that point. But my wife was having very similar problems with her stock, unrooted EVO 4G, so I blamed Sprint. It does not seem to be a Sprint thing.

I went back to Eternity 3.01, and the problem remained.

I went to MeanRom, (first 1.9, now 2.2) and the problem remained.

I tried integrating with google voice and sending calls through Groove IP. That worked over wifi, but the call quality sucked so bad over 3g/4g for me that I backed it out. Plus I thought I was introducing far too many variables.

So. I seek advice. I don't really want to restore factory defaults. Do I try going back to a previous radio version? The ones I'm on worked fine initially and they still do as long as the screen is on (and I can call out fine), so I didn't think it would be that, but maybe these ICS ROMS have flashed custom kernels that lost something in translation?

Experienced programmers can easily see that I know just enough to be dangerous, but I'm generally very careful. Not sure what's happened here.

Thanks in advance for your response.
 

Attachments

  • .jpg
    .jpg
    46.3 KB · Views: 30
Thats an interesting problem.

Did you make a nandroid of prior roms?
Has restoring those changed anything?

Also - Check your Quiet hours...make sure its not set to 24 hrs....






Hi all -

Looks like I need some help. Basically, my EVO 3d has stopped ringing when the screen is off. This has been going on for weeks. It doesn't ring, and I don't get a missed call notification. It just goes to voicemail. If the screen is on, it rings.

I have tried all the settings.

I am rooted. S-OFF. Currently running MeanRomICS 2.2 and I really like it. But.. I do need my phone to actually work as a phone.

The last time everything was working, I was running Infected Eternity ROM 3.01. At that time, I flashed the latest radios. First I flashed 0.97.10.0808 because it contained the latest Wifi update, then I flashed 1.06.00.1216. And everything worked. I did seem to think that I wasn't getting any noticeably better performance, but the problem I describe had not surfaced.

I wanted to try an ICS ROM so I flashed Chubbz Booster Shot RC2 ROM. It seems like my phone stopped ringing at that point. But my wife was having very similar problems with her stock, unrooted EVO 4G, so I blamed Sprint. It does not seem to be a Sprint thing.

I went back to Eternity 3.01, and the problem remained.

I went to MeanRom, (first 1.9, now 2.2) and the problem remained.

I tried integrating with google voice and sending calls through Groove IP. That worked over wifi, but the call quality sucked so bad over 3g/4g for me that I backed it out. Plus I thought I was introducing far too many variables.

So. I seek advice. I don't really want to restore factory defaults. Do I try going back to a previous radio version? The ones I'm on worked fine initially and they still do as long as the screen is on (and I can call out fine), so I didn't think it would be that, but maybe these ICS ROMS have flashed custom kernels that lost something in translation?

Experienced programmers can easily see that I know just enough to be dangerous, but I'm generally very careful. Not sure what's happened here.

Thanks in advance for your response.
 
  • Like
Reactions: graham722
Upvote 0
Thanks MahaloCat -

Yeah, I made nandroid backups before flashing new Roms. You'd think I would have done that already, but actually, when I thought it through - I had not. Instead of restoring my backup of Eternity, I flashed the latest nightlies version (I had previously been on the most recent stable release).

I did actually restore from backup the earlier nandroid today and guess what - my phone rings again. No clue what the deal was with the ICS roms and the Eternity nightlies. Maybe I should start over with a wipe and a clean install of MeanROM? I was reading on xda about power saving changes to the kernel in ICS that caused this exact same problem with Galaxy Nexus devices. I wonder if it's related somehow.

Anyway - I should have restored from backup before posting, but it's still a big mystery to me. Thanks again, and if anyone else has useful input or speculation, please share.
 
Upvote 0
It could be that your phone doesn't like the CPU tweaks in MeanROM and it when it goes into deep sleep, it doesn't come out of it for phone calls.

I would try a different ROM than MeanROM. I would have similar wake problems with it. Try ZR3D.

fyi - ZR3D 4.1B does exactly the same thing. Nothing comes through, and when I turn the screen on, my phone bars are gray with an "X" over them. They come back within a second of turning the screen on.

I noticed the ROM features "less power consumption" - I assume it's in these power save tweaks that I'm getting screwed. I'm going to email the dev and see if he responds with ideas. Otherwise I'll try flashing back to an old radio. I don't know what else to try (other than yet another ROM or restoring to full stock). I would stick with Eternity, but I get 2-3 random reboots a day and that drives me absolutely crazy.
 
Upvote 0
well I've been living with this thing for awhile - mainly because I've been busy and don't mind most of my calls going to voicemail. Plus, I discovered that if the phone was charging, the radio didn't lose connection and it rang properly.

But just to close the loop, and if anyone else is having the same issue and searching for a meaningful solution, I did fix it today by flashing an earlier radio from the 2.08.651.2 OTA.

I should have tried it sooner, but flashing radios is not something I want to make a habit of, and I really am surprised that it worked. It makes no sense to me, but then, I don't understand the OS at that deep a level. So there you have it, I'm now up and running with all systems go. I haven't gone back to my MeanRom backup yet because I really like ZR3D.
 
Upvote 0
Try Zred ICS 2.1 and stick with the stock kernel assigned to it, report back



fyi - ZR3D 4.1B does exactly the same thing. Nothing comes through, and when I turn the screen on, my phone bars are gray with an "X" over them. They come back within a second of turning the screen on.

I noticed the ROM features "less power consumption" - I assume it's in these power save tweaks that I'm getting screwed. I'm going to email the dev and see if he responds with ideas. Otherwise I'll try flashing back to an old radio. I don't know what else to try (other than yet another ROM or restoring to full stock). I would stick with Eternity, but I get 2-3 random reboots a day and that drives me absolutely crazy.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones