• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

CDMA Hero stuck on white "htc" screen


Aug 29, 2011
Hi everyone,
While I have been lurking for quite a while, finally gathering up the courage today to root my Sprint Hero (as well as my Iconia tab) - I'm ashamed to say that my very first post would be a request for support.

Anyways, here is what happened:

Decided to root the phone today - since I had a current build #, I had to revert to earlier build. Long story short, used the AndRoot method and it worked flawlessly. So, feeling the high that immediately comes with superuser access, I decided to install a custom ROM.

I followed the directions and installed ROM manager, saved a backup rom, and then downloaded and saved the following ROM to my SD: VillainROM13
So, booting into Clockworkmod, I was able to wipe and flash the new ROM. Installation completed, but when I rebooted, It was stuck on the opening "htc" screen for twenty minutes before I decided to remove the battery and retry the whole process. Still the same problem..
I have tried numerous other ROMs, hoping that I may have had a corrupted version, but I am still stuck on the white htc screen.

Any ideas? I can still get into clockworkmod, so I'm thinking there may still be hope.

Thanks in advance!

Tried to restore while in recovery - getting the following error:

Checking MD5 sums...
Erasing boot before restore...
Restoring boot image...
Error while flashing boot image!

If I go into advanced restore, I can successfully run the individual restores, except the boot restore. I keep getting the error above. Did some research, and learned that my battery has to be fully charged, so I made sure of that. I also copied my SD card to my PC, formatted the SD card, and re-copied everything back onto the card. Still no dice.

I did notice that in the fastboot mode, it shows:

I'm worried about the "S-ON". I rooted my phone before taking this all on, so did something happen to my privileges at some point?
Upvote 0
Moving thread to the root section. S-ON should not matter when flashing ROMs and other stuff with the Sprint HTC Hero.

It sounds like your Nandroid backup is corrupted. The Androot method and VillianROM are pretty old at this point. I would recommend getting back to stock via the Android 2.1 RUU and then rooting again via Z4Root. Finally, go with a modern ROM like AOSP Android 2.3 or CyanogenMod 7.1.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.