• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Could a firmware update to 1.6 break the mic + ear-speaker?


Sep 7, 2009
Hello all,

My Galaxy recently went quiet while making phone calls, i.e. the ear-speaker and the microphone both stopped working; I tried the in call volume, but that wasn't it.

I tried re-flashing to 1.5 because I was thinking that it was a hardware problem and I would have to return it; that didn't fix it either, so I took it back to an O2 shop for repair.

I was a bit annoyed with the man in the shop, because he put in the fault report that the phone crashed all the time which it didn't and I didn't say that it did - I'm a software developer and I appreciate that good bug/fault reports are invaluable. I suspect he "analysed" the problem and was "helping" by hinting at a solution for the repair centre. :thinking:

However, when I picked up the phone today, it has version "I7500XXIK4" of the firmware, the mic and speaker work and the repair details say that the repair was to flash to the latest version of the firmware and did I know that software ought to be kept up-to-date (yes, version 2.1 would be nice Samsung ;)).

Anyway - this doesn't sound like a firmware problem to me. What does everyone think?

Also, if you think that it might be the possible cause, this makes me wary to flash back to 1.6 firmware. What would you do?

Thanks for your input...

no its not 1.6
it could have been firmware
more likely the headset glitch where you need to insert and remove the headset in rapid succession to free the dirt and short in the jack that causes the device to be stuck in headset mode.
there are posts about it.
its more likely the repair center flashed it, cleaned it and it worked but its likely the cleaning was the fix
  • Like
Reactions: timmydog
Upvote 0
I cannot believe it hehe, the exactly same thing happened to me, but for a different reason.
On a random sunny day my mic and ear-speaker went dead. Also the normal music playing speaker went dead. I had jc6 installed at the time so i went back to ik5 but it didn't help, next i tried ii5 and it still didnt work.
So i left the ii5 on the phone and took it for repairs under guarantee.
The funny thing was that the guy at the repair shop had the same phone, so we talked for like and hour about different roms, about drakaz and Galaxo and about how we got screwed over buying the Galaxy ofcourse. He seemed nice so i told him what roms i had on and that it wasnt a software error, since it stoped working without changing any settings and the guy wrote down the problems and send it to repairs, no questions asked. Was kindda risky though, he could have easily said i broke the phone using 3rd party software as i mentioned i had Galaxo on for a while, but as i said he was nice and that wasnt the case, lucky me :)
A week later i got it back ( was fast, it took 35 days for my Nokia repairs ) and there was ik4 installed ( im guesing coz its the last official release or was at that time ) and under repairs it said they changed some connector, nothing about updating my software, but im sure they did as i never had ik4 to begin with.

So, it wasn't software in my case and i realy doubt it was in yours.

EDIT: sry for my bad english, too lazy to go over it again :)
Upvote 0
more likely the headset glitch where you need to insert and remove the headset in rapid succession to free the dirt and short in the jack that causes the device to be stuck in headset mode.

Ah that could be it - thanks for the info.

there are posts about it.

I did search - honest - I'm obviously losing my 733t hax0r skillz as I get older. :p

Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.