• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Eris Stuck On Boot Screen

Hello,

My boyfriend just bought a Droid Eris (literally got it maybe a month or so ago) and now, all of the sudden, it's replaying the boot screen over and over again. It goes from the "skateboarder droid" to the Verizon startup then to the HTC logo and keeps replaying that sequence.

I've tried holding the volume down and power buttons at the same time and then went to "recovery" but once it gets to the Triangle-Exclamation-Point icon, I don't know what to do. I've looked at other forums and found no help.

I've also tried to mount it to my Mac via USB and had no luck at all.
I'm kind of a n00b so easy on the instructions, please! Any help would be really appreciated!

Thanks,
Ashley
 
Upvote 0
Have you tried pulling the battery? If that doesn't work go here if he downloaded the OTA:

http://androidforums.com/htc-droid-eris/78440-installing-ota-2-1-file.html

OR here if you downloaded the leaked 2.1

http://androidforums.com/htc-droid-eris/51383-upgrading-2-1-tutorial.html

Follow the instructions in those threads to reflash and start fresh.

Do not do both of those options. Choose one or the other.
Do NOT flash the leak, only the OTA. You will miss out on many opportunities if you flash the leaks. The OTA is out so flash it with that.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones