• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Firmware update stopped midway - connection time out

azteck

Lurker
Feb 4, 2011
1
0
Hello!

When I first wanted to update my firmware from 2.1 to 2.2 on Samsung Galaxy S, Kies gave me an Unknown Error Update Failed message.
A few days later I found an update for Kies so after updating I tried Firmware Update again and it started working. when it was downloading stuff for android 2.2 it stopped on midway saying something about connection timeout and a confirm button. pushing it everything stopped and Kies now doesn't recognize that it didn't updated the firmware and does not allow it(right clicking the device in Kies in the list the Firmware Update appears grey - cant click).

I have done a factory reset and deleted everything, reinstalled Kies and still doesn't work. Although Kies recognizes my phone but there's no notification that firmware update is available...

Can anyone help please? Can I do a firmware update ever again?
 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones