• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Frustrated trying to unroot my phone with the prescribed process!

I have a rooted HTC INC (with Unrevoked), which must be returned to Verizon, following a warrantee replacement (my screen had a problem staying on per the settings). I have also been unexpectedly laid off from my job after nearly two decades, so if I'm forced to pay the Verizon warrantee police it will be a serious problem for me. It's a mean bind I'm in, and the goto solution isn't helping, so I need all the help I can get.

I have been struggling since Wednesday with the widely-referred-to-process for unrooting an HTC Droid, which for most people has been incredibly simple. Every forum post, including some in this one, sends you to this video: How to: Root and Unroot the Droid Incredible - Droid Life: A Droid Community Blog or to this forum post: How to correctly unroot the Incredible - Droid Forum - Verizon Droid & the Motorola Droid Forum, which I have actively queried as "Arpeggiate". I seem to be the only one there who has known problems such as mine, despite the fact that I am checking for and doing everything which they have elaborated on so far:

1. My radio is RADIO-2-15-00-07-28, which is prior to the as-warned-of RADIO -2-15-00-09-01 in the disclaimer.

2. I do not have an SLCD screen, mine is about six months old and AMOLED.

3. I successfully switched the s back to "on" with the "unrevoked-forever- son.zip" file.

4. I have formatted my SD drive to fat32.

5. I have copied the "PB31IMG.zip" file to the root of my SD drive (and it sits alone there).

6. I'm not using a Mac, nor any OS with the policy of unpacking any .zip file which it sees.

7. I wonder if this makes the difference for me, that the phone which I am trying to ready for sending back has already been reset and disconnected!

8. Some people of no apparent authority on Doug Piston's home forum suggested that I did not follow "to the letter" making the file name in my SD root "PB31IMG", without the root. Doug did not specify this in his video (if that was his video), nor did the mod on his home forum, who was kinda inappropriately involved, and seemed more interested in protecting Doug from anything which doesn't begin with "It worked!" than in helping those for whom the problem could not be so easily solved. I mean no disrespect to Doug, who deserves much credit for what he has accomplished, but there doesn't seem to be anyone between himself and his fan club who has current interest in sorting out whatever the reason is (none which they could suggest) that it doesn't work on my phone. All I get there now is the song and dance that it worked for everyone else who wasn't failing to use and do at least one of the above, when nobody's denying that I have seen to all of that! Anyway, I went and renamed it without the zip extension, and HBOOT found absolutely nothing to do anything with.

What happened when I tried to run "PB31IMG.zip" in HBOOT was a wait for the file to load, then HBOOT ran a check on that file, and then I got the message:
"Main Version is Older!" Then, in red print,
"Update Fail!"
I renamed the file without the ".zip" extension (which Doug did not concisely say, although it was sort of suggested in his post), and nothing happened at all in HBOOT, and Doug's response to this was to try a different SD card, which I did, same format (reformatted today), with exactly the same results. Now I'm stuck, and would appreciate any help from anybody who has more ideas about the cause of that persistent Ninja on my phone. Please!
Upvote 0
What version of hboot are you using? It may need to be upgraded.

Have you checked the md5 of the pb31img.zip?
Uh-oh, what is that? Wikipedia says "a widely used cryptographic hash function with a 128-bit hash value. Specified in RFC 1321, MD5 has been employed in a wide variety of security applications, and is also commonly used to check the integrity of files. However, it has been shown that MD5 is not collision resistant;[3] as such, MD5 is not suitable for applications like SSL certificates or digital signatures that rely on this property. An MD5 hash is typically expressed as a 32-digit hexadecimal number." Well, what's the best way of checking it, and what can I do about it anyway?

Where did you obtain the file from?
Oh, the guy only listed working download sites on the thread which he then superseded! The link, and it's mirrors are listed here: [VIDEO] HowTo UnRoot Incredible by downgrading - Droid Forum - Verizon Droid & the Motorola Droid Forum. I am currently using the file from RapidShare, which I switched to after no success with the one from Megashares.
Upvote 0
You need to download an md5 checker, it verifies that the file you are downloading isn't corrupt. The link I posted above will direct you to one in the second post. I recommend following that guide and redownloading the file from the links provided in the post.

Success - and you are a god!

It was the file, and all I needed was a good one! I believe the problem is with the failure of the Droid Forums site to delete the original, and out-of-date thread through which I downloaded the files. Although the new thread does in fact offer a link to the newer file, there is no concision regarding it's purpose for those who visited the old thread first! They could have been more responsible concerning this, but anyway thanks for your help. This has been such a nightmare, which could have been prevented, and unfortunately Google all-too-often top-lists the punky links.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.