• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help HTC Desire Z no 3G


Feb 10, 2011

I have two phones Samsung S and HTC Desire Z

I can get 3G working on the Samsung but not the HTC Desire Z so I know the sim is working.

So far I have gone to menu, settings, wireless & networks, mobile network (on), mobile networks gsm dotted.

But it still won't go onto 3G.

Please can anybody help me?

In Settings/Wireless & networks/Mobile networks, ensure that (a) Network Mode is not set to "GSM only" and (b) "Enable always-on mobile data" is checked.

Hi Slug

I have changed it so it is not set to GSM only, I have changed it to WCDMA and it does not work, I have tried GSM/WCDMA also with also the enable mobile data ticked and it is still not working.

Do you think there is components missing on the phone that need downloading?

Upvote 0
That's how my own is set up and 3G/H kicks in whenever data xfer is needed. :thinking:

Where are you located and which carrier do you use? Maybe there's someone on the same network reading this who can compare settings.

I am in Huddersfield, I am with T mobile, I can access the internet with my Samsung S phone but not with my HTC Desire Z (which I find most strange).

I am a bit lost on what to do to be honest.

Upvote 0
I can access the internet with my Samsung S phone but not with my HTC Desire Z (which I find most strange).

Okay, try this....

Swap your T-Mo SIM into the Samsung, boot it up, go to Setting/Wireless & networks/Mobile networks/Access Point Names, and make a note of the default APN settings i.e the APN that is marked as active. Then replace the SIM in the DZ and compare its APN settings with those you noted.
Upvote 0
Hi All

My HTC Desire Z stooped working on the mobile internet.. No 3g etc..
Checked everything but could not find anything worry bar..
The APN's listing was missing.
I'm on Vodafone, so i phoned them and a very nice tech girl sorted it out with in 2 minutes!

For some reason all it had was Vodafone PAYG setting and not "contract" setting.

Once we had installed the right settings it worked!

Menu/settings/wireless & networks/mobile networks/Access point names/

Settings for Vodafone contract are:

Name: Vodafone Wap
APN: wap.vodafone.co.uk
Port: 8799
User: wap
Password: wap

Click save.

If not you airtime supplier.. Give them a ring for the settings.

Neil T
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.