• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Huawei G615 (U9508) softbricked (bootloop) or battery problem – How to flash?


I desperately address you today to ask you for help with my Huawei G615 (U9508; 1GB Version so it’s not Honor2/U9508B, but shouldn’t make a difference).

- Phone won’t turn on (seems to be a bootloop).
- Phone won’t charge.
- Can’t find many of the needed files for flashing. So I need working mirrors or would appreciate uploads.

Early 2013: Bought, standard Android 4.0.4 version, rooted by myself.
April 2015: Updated/Flashed to official (?) 4.2.2 with EmotionUI 1.6, rooted afterwards. Since then (not sure, maybe it’s unrelated to the update), I had multiple, annoying error messages when Wi-Fi got (re-)connected, but ignored it for months for not finding a solution.
Indeterminate timespan: State of battery charged wasn’t shown correctly, phone shut off too early. Used app “Battery Recalibrator” to fix this, needed some attempts but finally worked.
16th Feb. 2017 (Day X): Accidentally dropped phone (1-meter drop height, good TPU/silicon phone case cushioned it; no visible damage to phone or battery, no software-crash). Phone continued to work normally. Charged it to 100% before sleeping.
X+1: Phone was 99% after waking up, then suddenly 12%, shut down on 10%. Showed 0% afterwards, plugging it in to charge didn’t help. Despite charging it says 0%, powering on (only possible when charger plugged in) leads to bootloop (Huawei Logo, Android Logo, Huawei Logo (because it restarts)). Decided to put the phone on the cool window board over night without charging it.
X+2: Tried again to turn it on, after many attempts it magically turned on. Worked for the whole day, I still tried to flash the phone to get rid of my other Wi-Fi error log problem (and to prevent other possible problems by doing a fresh new start), didn’t seem to work. Charged it to 100%.
X+3 (today): Phone was already powered off when I woke up. Still can’t turn it on.

What I also tried continually:
- Tried charging with different power adapters or directly from USB. Still 0%.
- Tried wiping cache, wiping/factory reset.
- Flashing it to official 4.0.4. and 4.2.2., seemed not to work because it was over after some seconds, but the SDROOT/dload folder is ~1GB (although it said it worked, see spoiler).
When in recovery and choosing “apply update from external storage”, and then “dload” it says it failed to mount /sdcard (E:; “no such file or directory”).
Then error to open /sdcard/dload (“no such file or directory”)
“Install from SD card complete.
cust copying files.
copy cust files succeeded.”
But as I said, that's possibly not true that 1GB gets copied in some seconds.

Status now (as I remember from Day X+2 when it worked):
- 4.2.2
- EmUI 1.6
- Android system recovery <3e>
- USB-debugging should be turned on (not sure) and phone should be rooted (Superuser was still installed after wiping, but it said it needed an update, so it might not fully work).
- Kernel and other software stuff: Can’t remember, can’t turn on the phone. And don’t know what they all mean tbh, I’m glad I know a little about the differences of Android official and custom ROMs and what a recovery is (and that I may need the Chinese recovery for flashing I cannot find online).

Further Details:
I personally don’t think the fall caused my problems because it continued to work for the whole day and the drop was cushioned. What I suspected: It could be an extreme case of the battery charge status problem. The phone thinks the battery is still 0% although it’s not. So it shuts itself off. Or the bootloop is caused by faulty software/ROM, although I didn’t change anything before the problems appeared. As recovery mode (Power + VolumeUp) works and the phone can be on for hours when in this mode (as long as it's plugged in), I assume that it's not the battery but a soft/firmware problem.
I’ve read through several manuals and now get some sense of the topic, but I still don’t know everything relevant. Also, most of the links to important files are dead.
In addition, a problem I have is that despite reading through lots of threads, they require me to have a working phone, but mine is stuck in a bootloop.

What I want:
A clear, new phone software. Doesn’t matter which Android version or if official or custom ROM. Just want a working phone without the Wi-Fi error, so a fresh new start, a clean flash.
So: How do I do it, and importantly, where can I find the needed files?
(Even though I might buy a new phone next month, I want this one to be fixed so I can gift or sell the phone.)

Software I already have:
HiSuite, HuaWei_USB_Driver.exe, Android SDK, dload-B115 (folder, should be official Android 4.0.4), dload-B703 (folder, should be official Android 4.2.2), cm-10.1-20131006-EternityProject-hwu9508.zip (CyanogenMod 10.1 from Eternity Project); already rescued my data, so I’m ready to wipe.

Software that might be missing:
Chinese recovery, fastboot mod (what for?), CWM (what’s this, what for?), TWRP (what for?).

Many thanks in advance!


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.