• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [International] Help me fix my newb screwup...

Alright, so a few weeks ago I bought this phone, unlocked the bootloader, and rooted it so I can do as I please. Fast forward to tonight and I'm going thru some stuff using Titanium Backup and noticed Google Play Services had been updated. Not wanting that update to sit in /data, I hit "Integrate Update Into ROM"... well apparently this was a dumb idea. TiBU froze up, and even though I was able to force it to close, it seems to have corrupted Google Play Services on my device.

No worries, I'll just restore my NANDroid backup from CWM... or so I thought, til I got the message "Error restoring /data" in CWM. Hmm... ok wipe /data and try again. Still got the same error.

Okay I'll just ADB Push the Google Play Services APK to my phone and install it that way. Nope, when I try that it says "App Not Installed". Sure enough, I log into Google Play from my computer and it says Play Services is already installed... :hmmmm2: (How does it determine this?)

Alright let me try something else. Wipe Dalvik, cache, data, and try to install Carbon ROM since I don't have a clean factory ROM image. Well that was a mess... com.android.phone and a whole lot of other stuff was crashing. Flash back to my NANDroid backup (still says "Error restoring /data") and here I am.

What can I do to reinstall Google Play Services? Or do I need to do more than just that?

Phone is currently back on the NANDroid backup of factory ROM with a failed /data recovery, and my computer is running Linux (Ubuntu 12.04 LTS) with ADB installed.

Thanks for any help!
 
Well, I tried to change the thread title to reflect that I fixed the issue, but I guess that ain't possible.

Anyhow, I got 'er fixed. Went back to Titanium Backup and was looking for any trace of Play Services, when I found the option to "Extract From Nandroid Backup"... NICE!

So I extracted what I needed and installed it without a problem... everything's back to normal!

Now to figure out why CWM couldn't restore my /data partition...
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones