• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Moment sees 2-4 satellites, but never locks on my location


Nov 6, 2009
Using gps status, my moment will see 2-4 satellites, but never locks on my location. Ive tried everything, factory restore, changing gps/wireless networks, everything. I used google maps over the weekend while driving, and it was working, not great, but it was able to atleast lock on my location. This morning, it just plain stopped working. It is raining pretty bad here in los angleles, but like I said, it sees the satellites just fine, just no lock. Could the cloudy skys be the issue?
Just a suggestion, but I'm telling you that turning on my Wi-Fi has worked wonders for my GPS.
I'm not talking about "use wireless networks" under the Location setting, but actually turning on your Wi-Fi that is under a different settings option.
Have you tried turning on your Wi-Fi then trying to use your GPS? It has made a huge difference with my phone that would put me all over the map on Google Maps, and now it will lock right onto pretty much my exact location w/ in 5 seconds with my Wi-Fi turned on before I go to a GPS using app.
If this works for you, check out my post that I put under Tips n Tricks. I also mention a quick n easy to turn your Wi-Fi on right before you use GPS, and then turn it off when you're done w/ GPS.
Hope this works for you.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.