• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help New SD Card Won’t Mount

I have bought a new 16 GB SanDisk SD card for my Samsung Galaxy S (GT-I9000, Android 2.3.6). Using my computer, I uploaded my music and some pictures. Then, I first mounted the SD card to my Samsung tablet and copied the music files to it, because it has enough free space. After copying was completed, I ejected the card and finally inserted it into my smartphone. But when I went to My Files, the external_sd folder was empty and no music files appeared in the Music app. I went to the settings and manually clicked Mount SD card, and a notification Preparing SD card appeared and disappeared shortly afterwards, but nothing happened. I again inserted the card into my computer only to find out that it was damaged, and I had to format it. I tried again with copying my files to the card, but it still doesn’t work when I insert it into my phone.
Before this SD card I have been using another one and never had issues.

Does anyone know how to fix this? If you have any further questions, do ask.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.