• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help pc mount and ics 4.0.3 recovery black screen

When i was using gingerbread 2.3.4 (rooted), my nexus s is not connecting to pc. pc is not taking its driver. i tried so much by some adb driver and also Samsung's latest drivers. but still it is not connecting.

And also having this problem, i make a stupidity by upgrading to the official ics 4.0.3.

In ics 4.0.3 in bootloader mode it is showing black screen and still not connecting to pc. When i connect it shows as unknown device. And i update driver is takes as usb input device or HID-compliant consumer control device.

In 2.3.4 in have installed clockwork recovery mode

Ics 4.0.3 can't be root because of this problem..

Now i cant do any recovery without root bcoz it needs recovery mode. And cant connect to pc to act fastboot.

Plz give me some suggestions.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.