• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Phone hangs at HCT-screen after ROM Backup


Apr 20, 2011
I have HTC desire, fully working, rooted and Leedroid ROM.

I want to make backup of my current ROM since everything now is how I want it. I use ROM Manager -> Backup Current ROM. Everything runs smoothly, until the phone restarts. Then the phone hangs at det HTC-screen FOREVER. I have tried waited at least 15-20 minutes. Nothing happenes.

Luckily for me I have an old backup, so I use this in Recovery. When I look at my SD-card I can see that there actually is a backup (the new backup) made of my phone, so I tried to use this backup. Everything goes great. I get the message that the phone is successfully restored, but when I reboot I get the same error. The phone hangs on the HTC-screen.

So what could be the problem? The old backup works fine - but the new backup does not work.....

There is a known issue that the first backup causes a boot loop / hang. But restoring of this backup should fix the issue.

Your new backup could be corrupt. Try take a new backup and then see what happens. If you can still boot, try and restore it.

Also DO NOT USE ROM MANAGER. Use recovery MANUALLY. ROM manager causes many backup issues. See rooting FAQ linked in my sig for how to use recovery manually.

We are seeing about 1 thread a day of issues caused by people using ROM manager, so I am in no doubt that this is your problem.
Upvote 0
Ok, I tried this again, but this time I made backup manually from recovery. Backup was successful. When I then rebooted - same thing happened - HTC screen froze. I then booted again into recovery and restored my recent backup. The restore was successful - According to recovery. But When I then rebooted the system - Same thing happened....

This really sucks. My old (and only) backup still works, so my phone is working again, but of course with all my older settings.....

Any suggestions?
Upvote 0
I used "Reboot into Recovery" from ROM Manager. But can this have anything to do with this? After all tere is a complete reboot, AND my OLD backup still works...:thinking::thinking:



boot to recovery using voldown+power and then select recovery

how did you root? unrevoked?
Upvote 0
I used "Reboot into Recovery" from ROM Manager.

I had a hunch. By doing this you are still using rom manager's fake flash of cwm so you are not avoiding any of the rom manager created issues we want you to avoid.

Also aswell as uninstalling rom manager, locate "update.zip" on your sd card (the rom manager fakeflash of cwm and delete it, to avoid when you are in real recovery - accidentally "apply update.zip" and loading the fake flash version.
Upvote 0
Still does not work!
This is what I did:
- Uninstalled ROM Manager
- Deleted update.zip from my SD-card
- Rebooted into recovery (Vol down+power)
- Backed up my phone (Success)
- Rebooted -> Hangs on HTC Screen
- Rebooted into recovery again (Vol down+power)
- Restored the backup I just created (Success)
- Rebooted -> Hangs on HTC Screen

So it seems like I have to stick with my old backup....

Is there anything else I can try? I have read someting about a complete wipe of the phone? Should I format my SD-card??
Upvote 0
please read our guides, specifically the a2sd ones as they mention about using gparted to create ext partitions this can also format the card

yes rom manager could well have caused this problem if it created the ext as it has issues some times with partitioning

So I basically have to start all over again to make sure I can make backups of my ROMs.... Format everything, including ext3 partition, Flash the ROM again, and start from the beginning, and avoid using ROM Manager for all future.....

Thanx for all help so far. Will stick around with my old backup for a while, but will post here again with my results when I try again,

Cheers :)
Upvote 0
Just one more question;

Is there a way I can reset EVERYTHING and start all over from scratch?
After all this trouble, I would imagine flashing the ROM again still wont work....

I tried formatting the SD-card and did a system and cache wipe from recovery. Same problem....

Is there an easy way to unroot and just go back to the original Stock ROM?
Upvote 0

So it turns out it was not the ROM Manager or anything else that caused this.... It was actually the ROM. I have Leedroid ROM and the USB Debugging issue that caused this.

My first and only working backup had USB Debugging enabled. But I have always disabled USB Debugging after this, so when I reboooted, it froze.

I have Leedroid 2.4.1 and this issue was supposed to be fixed in this release, but IT IS NOT FIXED!!! (Warning to others)....

So after hours of frustration, I have finally solved this. Thank for all your help. I will of course stop using ROM Manager even though this wasn
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.