• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Rooting Verizon LG G3 ADB connection


Sep 20, 2014
I wasn't sure where to leave this info, but it would have saved me a lot of time if it were here already.

After struggling to connect ADB to my LG G3 in the process of using ioroot, I found that ADB required me to set my USB connection to "Internet connection" with subtype "ethernet" before it would show up in adb devices command.

This, after trying unsuccessfully the USB connection types MTP and Camera. Once this step was achieved, it was straightforward and good. The phone rooting worked using ioroot on my VS98510b device running Android 4.4.2.

Solution idea came from an xda thread.
  • Like
Reactions: Mikestony

Found the idea of that setting in this thread: [SOLVED] Unable to access with ADB/No RSA Fi… | Verizon LG G3 | XDA Forums

Specifically this part:

Try using this set of Vertizon g3 drivers: https://mega.co.nz/#!58YHAZaQ!yNlgZG...mmiDrNq9W5aJIc

Open the .zip, run the .msi file on Windows.

I do not run the G3's auto-install software when I plug it into the PC.

I do set the G3 to "PTP" USB before initially connecting to the PC.

The adb file in the ioroot "bts" subfolder should be okay to run on Windows.

When the phone is attached to the PC, change its USB connection type to Internet, with submenu type Ethernet. At least on my phone, right when I change the phone connection to Internet/Ethernet is when I get the phone popup to accept the PC's RSA fingerprint.

If I then run "adb devices" on my PC, I'll see the random ID followed by "attached", which means I have a good connection. If this doesn't happen, unplug, then replug, the USB connection at the PC side.

Then I can "cd .." and run ioroot.bat.

Good luck!
  • Like
Reactions: Mikestony
Upvote 0
oh nice! I'll have to try that as I keep getting the serial number with the "unauthorized" bit :(

Edit: holy crap it worked!! (the part of the solution about deleting the "adbkey" (s)).
I ran a search for "adbkey" and deleted both the "adbkey" and the "adbkeyPUB".

Put my phone into USB connection to "Internet connection" with subtype "ethernet" as you did, started ADB, and voila!! Serial number and "attached"!! No more "unauthorized"!!

I did notice a popup on my device where it asked me something about the computer ADBkey and if I wanted to connect--or something like that.

This is exciting for me. as I put that issue on the back burner of things to investigate later, but now it is solved!

Now granted I am rooted already via Stumproot, so that should help others trying to root with ioroot!!
Upvote 0
Ah, great. Glad this helped. I also found and deleted that key file for good measure, but I wasn't even getting as far as having the "unauthorized" error. I was just getting no connection at all.

That Voice Mate program popping up when plugged into a speaker is totally fixable if you use the Titanium Backup (root) program in the pro version--just freeze the related Voice Mate apps. Anyway, that's what I was primarily trying to achieve. It's one of those apps you cannot delete without the root privs.

Consider the reddit threads on this, for instance: Is there any way to disable Voice Mate? : LGG3

How to disable Voice Mate? : LGG3
  • Like
Reactions: Mikestony
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.