• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Stuck on splashscreen after attempted update phone with official OTA - until next OTA kinda solved

Flumme

Android Enthusiast
Jun 29, 2011
335
89
Sweden
Hi guys!

I received a notification that a new update (official OTA) was available today. I choose to install right away with thephone attached to the charger (was at about 65 % battery), but the phone tried to reboot and will not get past the splashscreen (no reboots, it just sort of hanged).

After waiting for over an hour without any change, I've tried to force the damn phone to reboot and "take" the update, but it just reboots back to the splashscreen and hangs.

I am unable to turn the phone off, and I can't seem to get into the recovery mode where I am able to choose a hard reset.

Any tips on how to go forward on my own, or do I have to wait for the Samsung repair shop to open monday and get their help?
 
Kept trying to reboot last night in such a manner as to get the phone to "take" the update, or reaching recovery mode. Finally the phone started applying the update, and immediately rebooted and got stuck on the freaking splashscreen again.

Disconnected the phone I let the battery drain completely overnight. Tried to boot into recovery mode after connecting the charger and letting it charge for s little while. Failed to boot into recoverymode, but the phone suddenly decided to boot all the way, applying the update as it should have done from the very beginning.

This is the second OTA update the damn phone couldn't handle without getting stuck on the first reboot for over an hour.

Anyone else this happened to? If so, what did you do to fix it?
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones