• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Synced with my Gmail...but new mail doesn't automatically come


Dec 9, 2009
I used Google Domains / Apps for my mail..so instead of @gmail, I have mine @absolutebica.com

So I am logged in..everything is fine...I have my contacts, I can view my mail, etc... I have it set to AUTO-Sync everything.

however, when I send a test email to my account...it never shows up automatically. I am finding I have to physically go into my settings, data synronization, and manually sync my mail for anything new to show up.

Whats up? Is there a specific time limit set somewhere for when it checks for new mail?

You can set how often your phone syncs with gmail, by going to the menu/more/settings/send&receive/setdownloadfrequency tab and picking your choice.

If you figure out how to configure the "manual" choice, let me know, I've got it set on 5min right now, but would go to 1 or 2 . .


Are you talking about the "native" gmail support on the phone..or if you setup your gmail account manually via the "mail (HTC MAIL)" application (i.e;, you can choose pop, imap, exchange, etc..)?

I don't get those settings if I choose MENU from within gmail...or even in the Data Sync. settings in the SETTINGS area.

Can you elaborate please.

Upvote 0
Must be on the native email function, which I set up for gmail.

When I pull up the gmail lodo'd email I get different menu options.

But when I open mail through the widget that looks like a maibox with a bent flag, the menu options are as I described above.

Don't know why my setup had the mailbox instead of the gmail widget, but there you go.

try that one and holler back
Upvote 0
The only way to get "push" (instant) e-mails is with K-9 Mail.

I disagree. I don't use the stock e-mail app, I use the actual Gmail app. I turned off notifications for the stock one. When I get an e-mail, I instantly get a notification (or maybe within a few seconds or so). When I click on the notification, it takes me to the Gmail app and I can read the e-mail. Through some testing, I also found that this also does not affect my awake/sleep time, so I plan to keep it ;)

Inside the Gmail app's Settings, I have Email notifcations "checked" on. Not sure what else there is to set, really... I dunno...

Also, greetings all... Been reading here and finally decided to register :D

EDIT: Also, I am using an actual "@gmail" address, so I'm not sure if that makes a difference. Hope this helps.
Upvote 0
You "can" enable your gmail to use with the HTC mail app (non native gmail app). I am not sure what the K9 app is..unless they are one in the same.

Enable IMAP in your Gmail account settings online, and when choosing IMAP on the droid, just enter the respective settings that match up to this:

Outlook 2007 - Gmail Help for port numbers, smtp, etc...

btw - my native gmail app seems to be accepting emails now. not sure, at the time, why it was delayed.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.