• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help USB activates with Car Charger but not Computer

I'm very confused by this problem and I've tried nearly everything short of a factory reset to fix it.

The Problem:
When I connect my phone to my computer via the USB cable all it does is charge. I've tried it on at least 3 different computers and recently installed the driver software on my main computer, and still nothing.

The Confusing Problem:
When I connect my phone to my car charger the USB options come up - choosing between Media Player or Mass Storage Device. This is the USB setting I have on my phone; I've tried changing it, and still nothing.

I have no earthly idea why this happens.
Any help?
 
I didn't think my cable was the problem at all. The one I have is a replacement for the original because it stopped working a few months after I got the phone. When I went back to the store, an employee told me that they stopped making the particular model of cable I had. So he gave me another cable and told me it would work "just as well as the original."

Little did I know, until last night when I looked at the fine print on it, that it's an LG cell phone cable, not a Samsung. Great. Thanks for that link, I'm buying it right now.

As for the car charger, a friend told me that it probably was a connection problem within it. But as it works just fine, I guess I'll just have to deal with the annoyance of my phone doing that everytime I plug it in to my car.

Thanks for your help.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones