• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Wifi On The Desire - Connected But No Data?


May 28, 2010
Hi there,

Sorry of this has been dealt with before but I did try & search the first few pages of the sub forum.

I've had my desire for around a month now & had no real problems with it, flashed it with a stock rom initially & then rooted it a couple of days after the root was released.

When I woke up this morning I was connected to my Wifi network but when I tried to load a webpage, nothing happens, it comes up with the stock 'Web page not available' page. I tried a couple of web pages but got the same response, I thought it might be my Wifi network but when I got to work, exactly the same thing happens.

I can connect via GPRS when I disable the Wifi with no problem.

I've been using Y5 Battery Saver for the past two weeks, not sure if that's relevant.

Is this a standard error / known bug, how would I go about fixing this, not having Wifi is obviously a bit of pain!

Thanks in advance,



OK, installed a Terminal emulator over 3G & ran a couple of commands, including dmesg.

From the output of dmesg it looks like the Wifi connects but then something goes wrong, here's a brief transcript:

pfn: set ssid = **************
Link event
Link UP
Enter set packet filter
start to add pkt filter 101
wds: 0021 @ 01
qmi: wds: network stopped
wds: 0022 @ ff

If this is any use, I'm happy to try other commands.

OK, I think I've managed to work out what the problem is; the Desire doesn't seem to be able to use DNS to look up hostnames. When I try to ping Google using a terminal app, I don't get any response but when I try to ping the IP of Google directly, it returns straight away. I have confirmed this by visiting the IP address in my web browser & it does bring up the Google homepage.

Is there a way to check what DNS settings my phone is currently using or failing that, force it to re-request the settings?

Upvote 0
It'd more likely be the router not allocating the connection correctly for the phone.

What encryption are you using? If you use the app from market "wifi analyzer" do you see any channel congestion? Change the channel to the one recommended by that app.

The Desire isnt tolerant of channel signal congestion.
Upvote 0
I agree with nx1977. I've had the same problem. Desire tells me I'm connected to WiFi but no data downloads. I've just installed "WiFi Analyzer" from the Marketplace, it's a great app. It tells you which channels are congested and which is free (or least congested). Gives signal strength and all sorts. I've just retuned my router to channel 3 from 11 following info on wifi analyzer and Desire got connected and downloaded stuff straightaway.

Give it a go.
  • Like
Reactions: nx1977
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.