• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Xperia Play not showing up when plugged into USB

Thargor

Newbie
Dec 20, 2011
10
1
Hi, I rooted my phone today with the Zergrush thing and it seemed to work perfectly except when I came back in this evening and tried to connect to the laptop it makes the standard windows 'duh-dun' USB connection noise and the phone starts charging but the PC companion software doesn't auto-start like it usually does. So I started it manually from the Start Menu, it says no phone connected. Looked in Windows and its not there either as a usb hdd that I used to drag music and games to before now. Ive tried everything to get it to connect, I cant connect over wi-fi either as it has to find the phone in USB first.

USB tethering has stopped working aswell but strangely I can connect when using it as a wi-fi hotspot. Ive rebooted the phone and the pc several times now but nothing seems to work, it sounds like Im plugging a USB device in and out of Windows but nothing shows up.

Does anyone have any suggestions? Would a hard reset work or am I screwed?
 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones