• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Cannot sync Google contacts with PC

I cannot sync Google contacts between my Moto G6 and my Windows 10 PC. All other syncs(calendar, gmail, drive, etc.) work as they should. The last time contacts synced was 4/16/21.
At the bottom of the Google account page there is a message that says:
Sync is currently experiencing problems. It will be back shortly.

I hope this can be fixed.
Your online Google account is going to the central focal point for all the devices (mobile devices, desktop and laptop PC) to sync up with. Your Google account data resides in Google's online servers, so when it's an issue where you're having problems viewing your Contacts listing on your Win10 PC, that's an issue with your Win10 PC.
If the problem is a matter of you cannot get your Moto G6 to sync up with your Google account's Contacts, that's a different issue however. In that case, the issue is likely to be with your phone and your PC is irrelevant. Again, your online Google account is what all your gadgets get their data from. It is not a matter where your Moto G6 and your Win10 are syncing with each other, they're just both syncing to your online Google account.
So just to clarify, is the problem a matter of syncing with your PC as indicated in the title heading (this is an Android help forum) or is it indeed an issue with your Moto G6 as it's indirectly implied in your query?
Upvote 0
OK, since the problem does appear to be just a glitch with your Moto G6 can you think of anything that might have happened back in April, when the syncing apparently got messed up?
Try going into the Settings >> Accounts menu, open up the Google entry, and disable syncing for Contacts. Now go into the Settings >> Apps menu, find and open the Contacts app entry, tap on Force stop, then find and tap on Clear cache, then in the same app's Permissions menu un-select Contacts (I hope I'm not the only one that finds a Contacts entry in the Contacts app kind of inversely odd), and then reboot your phone. Now reverse things back (Settings >> Accounts >> Google and Settings >> Apps >> Contacts app >> Permissions), wait a few minutes and see if that makes any difference.

Do you have just one Google account set up on this phone? Or is it matter where you have your primary Google account and then an additional Google account and/or other email service (i.e.your primary Google account and a MS Outlook account)?
  • Like
Reactions: puppykickr
Upvote 0
Since all other apps sync correctly, I cannot recall anything I did to specifically screw up Contact syncing
I followed your suggestions and disabled syncing and forced stop of the app but could not find the clear cache icon. I booted the phone into recovery and wiped the cache. After reversing the steps, the sync problem persists. I have attached a screenshot which shows the message at the bottom: Sync is currently experiencing problems. It will be back shortly.
Only one Google account on the phone but I do have a pop3 mail account.
Upvote 0
So keep in mind that that there's a system cache that relates solely to the installed Android operating system on your phone, and then there are app caches that are used only by each respective app. All caches are just non-vital (don't retain important data) and temporary, but different processes running on your phone have to have them to function. When you booted up into your phone's Recovery, that involved wiping the system cache. There isn't a drawback in doing so (the system cache just gets rebuilt) but it's also typically not a necessary thing to do unless there's a reason to. Anyway, individual app caches are separate from the system cache and you need to use the Settings menu to manage them instead of booting up in to Recovery Mode. Try looking the Settings >> Apps >> Contacts app >> Storage menu. There should be options for Clear data and Clear cache (be careful not to inadvertently use Clear data instead, be sure to back up your contacts list first -- Export to vcf)

All that said, I doubt clearing the Contacts app cache is the actual source of the problem, it's just a standard thing to try when quirky app issues like this one pop up.
It doesn't to try though, and it might help.
At this point I'm out of suggestions on a fix. This is weird since things were apparently OK before and still are when syncing your other Google services, it's just Contacts. If you disable Contacts syncing in that Settings >> Apps >> Google menu and try to do a manual sync does that same error message occur? (... an option similar to 'Sync now' or words to that effect might be buried in a submenu or in an icon in the top or bottom menu bar.) Also, just to confirm are there indeed contact entries made after April 16th in your phone's Contacts app that aren't showing up in your online Google account Contacts (or vice-versa), or is it matter of syncing is working but there's just that error message stating otherwise?
Upvote 0
Try creating a temporary test contact entry either on your phone in the Contacts app or through your online Google account at
and then see if that test entry prompts the syncing process.
If you haven't actually done anything that involves the Contacts app or your Google account Contacts since April 16th, perhaps this is all just a matter where there was nothing to actually be synced that time. And if that is the case, don't forget to delete that test contact entry.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.