• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help needed: Kindle-app won't work


Nov 28, 2020
Dear people, I've been trying to get my Kindle-app to work on my Galaxy Tab A10. I've previously installed this app on my old Galaxy tab (bought in 2015, runs on Android 7).
I discovered today that suddenly Kindle uses a very strange password to send books to my Kindle-app. As I've used the same e-mail address for years now, I think something is wrong. It is using the same address but with some other letters in between. I'm sure I'm not hacked ;-).

Is there anybody here who can help me getting the Kindle-app to work again? I cannot reach anyone at Amazon.

Furthermore, I need to find a reliable app to read books with .acsm. I used to read these books with the Aldiko-app but that is not working anymore too.

I'm quite desperate...
I don't know about the Kindle app as I never use it, but how do you know it uses a "very strange password"? Surely its security isn't so weak that it can actually show you the password? But just to be safe (though I agree that odd characters in an address sounds more like a glitch) have you checked the security settings of your Amazon account? Enabled 2-factor authentication?

For .acsm format books, have you got a computer? Because one simple solution might be to install Calibre and use it to convert the format of those books to something more widely compatible (I don't know .acsm at all, but it handles most formats).
Upvote 0
Dear Hadron, I apologize! I meant to say 'e-mail address' instead of 'password' of course ;-(.
Yes, I have a computer. I can try and use Calibre. I already tried to work with Calibre on the tablet but I got the message that Calibre won't work on the tablet ;-(.
It is so strange! I can hardly be the only person who wants to use the Kindle-app on the Galaxy? I get my review books from certain sites for professional reviewers, so they are protected against copying. That is the .acsm format. It works absolutely fine on the old tablet.
I think I will have to find out how to convert the files and then send them to my Kindle-app.
Upvote 0
That prompted me to look up what .acsm is: it seems that it's an Adobe download manager interface, and that the actual book is downloaded as a DRM-protected epub. I guess Aldiko must have had some way of identifying itself as "authorised" for those files. Not sure what the best alternative would be: Adobe would tell you it's "Adobe Digital Editions", but that's one of the worst-reviewed apps in the Play Store :(

(Of course there are ways of removing DRM, allowing you to use whatever software you like to read it, but if you are reviewing professionally that may be a breach of trust).
  • Like
Reactions: MrJavi and ocnbrze
Upvote 0
Well… this morning I was in for a surprise. I started up my tablet and opened the Kindle app. And guess what? The books are there! I really don’t know what happened. Maybe it was the trick with the different e-mail address, maybe not (because I tried that yesterday). Anyway, that’s one problem solved, at least for books from Netgalley. I don’t know whether it works ok with Edelweiss yet. I only read a couple of books a year from Edelweiss so if necessary, I can do without.

I really don’t understand what happened but I’m happy that after 10 days of trying to get this fixed, and asking for help all over the Internet, it now works.

Thank you lovely people here for trying to help me! Your help gave me much more insight in the ‘inner workings’ of this tablet and the apps on it.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.