• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Android USUSB not recognised - settings completely disappeared


Aug 19, 2021
Good day,

Yesterday I connected my Huawei P30 Pro with Android version 10 to my PC with Windows 10 via USB as usual. The computer did not recognise the device as a USB device. So I tried to change some settings in the device. When I then switched off the developer mode, I was no longer able to select any USB-related settings in the settings. The entries still appeared in the menu and in the menu-internal search, but could no longer be selected.

I then tried to solve the problem by resetting the network settings. Now all the USB-related entries no longer even appear in the system settings. When I plug it in, however, the "USB usage" dialogue appears and when I select "Enter MIDI", the computer recognises the device. However, data transfer is not possible in any of the modes.

I would like to avoid resetting the device completely, is there another possibility, maybe reinstalling the USB driver manually or similar?

Many thanks in advance for your help!


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.