• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root [AT&T] CWM or TWRP won't take!

Bugler1

Newbie
Jul 23, 2012
16
8
MD
Can't really explain what happened but I have tried to flash both TWRP and CWM but neither seems to have taken. I choose to reboot into recovery and it goes to the htc screen, freezes for a minute then reboots normally. Any ideas? I am rooted and I did the htcdev unlock.

Thanks!
 
Do you have the Tegra 3 or S4 version?

Did you get any error messages when you flashed or did it appear to go through normally?

Connect the phone to the PC, open a command prompt, navigate to your fastboot folder (if you downloaded the fastboot files from HTC, there should also be an adb.exe file) and type the below:

Code:
adb reboot recovery

Does that take you to recovery?
 
  • Like
Reactions: Bugler1
Upvote 0
As an aside, when I first flashed the TWRP, I got it to boot into that recovery just once when the computer automatically restarted the phone after flashing. I can not get it into recovery again since then. I've tried reflashing twrp and different versions of CWM all to no avail. Trying to do a manual recovery boot or from CWM Rom Manager. Nothing seems to do the trick.
 
Upvote 0
Excellent, glad you've sorted it! :)

I've pretty much always used CWM on all my handsets, it does the job for me, so I don't see the reason to change (at the moment anyway). I suppose functionality is the same, just the UI is different? I'm led to believe the S4 One X (I've the Tegra 3 version) prefers TWRP so I'd stick with that.

And yeah, ROM Manager is sort of defunct nowadays, it's handy but I still prefer doing things manually.
 
  • Like
Reactions: Bugler1
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones