• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Can't instal apps!


Jan 22, 2018
I use an Alcatel U5, Android 7.0. I've been trying to instal several different cleanup apps, like Smart Kit 360 and others.Either they just keep showing 'pending' or some will say they are installed but also show 'no Devices found'.

Either way, I'm stuck, as I'm getting the same faults when trying to instal onto my Kindle Fire 7 (OK, different forum?)

Any ideas please?
Apps & notifications
See all
three dot menu in upper right
Show system
scroll to Google Play Services
Manage space
Clear all data
go back to the apps list
select Google Play Store
Clear cache (NOT CLEAR DATA)

Now try downloading again.

If it still fails, try restarting the device, and then try downloading again.
Upvote 0
Thank you puppykickr.

I managed to fix it but in a different way. I'm not sure how I got there but I went into Google Play settings and found 'My Devices' which showed that the device I was looking to fix was unticked. It seemed to me that it was worth ticking that box and then I found that it worked!

So I haven't tried your fix, which may well have fixed it anyway so thanks for the suggestion.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.