• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Galaxy S calendar won't sync with google

My Calendar app on my phone is not syncing with my Google Calendar properly.
I have a Galaxy S i19000M and updated to froyo.

When I got my phone 3 weeks ago I synced the calendar option with my google calendar (I have many google calendars related to each child, work, my husband and my other activities). It worked fine. Since then some things have gotten messed up:

1. I removed a calendar using my laptop online, yet I
 
By default, when you enter a new calendar entry, it goes to the phone calendar, which is not synchronized with Google calendar. In the calendar application on the phone you have to make sure you select your gmail account to save it to and not the default calendar stored on the phone. Otherwise they will not synchronize properly.

If you have multiple calendars and only some of the calendars are syncing, or none (new or old), you will have to do a factory reset and setup up your Google account on the phone again from the beginning. Before you do this though, log into your Google calender and make sure you selected all of your calendars that you wanted for import (display or view all by highlighting them on the left side on your screen). Once they are all selected, try syncing them again if you hadn't. If they are and they still haven't reappeared you may need to factory reset which may be the worst scenario.

However, they always say; "Did you turn off your phone (remove the battery- wait 15 seconds, replace battery) and turn it on again?" if you haven't, try that. Sometimes gadgets like a phone can be laggy.
 
  • Like
Reactions: sarahsunshine
Upvote 0
By default, when you enter a new calendar entry, it goes to the phone calendar, which is not synchronized with Google calendar. In the calendar application on the phone you have to make sure you select your gmail account to save it to and not the default calendar stored on the phone. Otherwise they will not synchronize properly.

Yep - I tried that at first and figured out how to save entried to the calendar I want. That's not the problem that I'm having here, unfortunately... otherwise I could fix it! ;)

If you have multiple calendars and only some of the calendars are syncing, or none (new or old), you will have to do a factory reset and setup up your Google account on the phone again from the beginning. Before you do this though, log into your Google calender and make sure you selected all of your calendars that you wanted for import (display or view all by highlighting them on the left side on your screen). Once they are all selected, try syncing them again if you hadn't. If they are and they still haven't reappeared you may need to factory reset which may be the worst scenario.
I assume you mean log into the web version of Google Calendars and turn those calendars on, then sync them on my phone (not somehow on Google Calendars). If taht's the case, I tried doing this several times in different configurations last night. I fear a factory reset is necessary... If I do a factory reset, will I have to upgrade to froyo again? That was a royal PITA and my laptop now gets a blue screen every 1/2hr since intalling Kies... That's what I fear....

However, they always say; "Did you turn off your phone (remove the battery- wait 15 seconds, replace battery) and turn it on again?" if you haven't, try that. Sometimes gadgets like a phone can be laggy.

Hadn't thought of that (should have). Tried but no such luck...

I gues I'll have to try the factory reset. Maybe the new version of Kies isn't so buggy? (prayer)
 
Upvote 0
It could be the firmware itself. Depending on the source in which you downloaded your 2.2 Froyo, you may have downloaded one that has bugs in it. Especially if now your laptop is having issues since downloading the KIES. I think factory resetting the phone is a dramatic move, nonetheless it is the only viable option. Have you removed the downloaded KIES off your system? If not, please do. If it is still buggy, try a system restore point before you downloaded the KIES (prior to doing this, if you have downloaded anything important you may want to save it on a USB key or external harddrive). Also, in regards to Froyo you cannot downgrade your firmware to what it once was (Enclair 2.1). You need to wait for an upgrade actually. Until then, a factory reset will help to eradicate all traces of Eclair (2.1) so they don't conflict with your Froyo (2.2). This may help all the glitches or awkwardness that you may be experiencing; along with the buggy Calender.
 
Upvote 0
It could be the firmware itself. Depending on the source in which you downloaded your 2.2 Froyo, you may have downloaded one that has bugs in it. Especially if now your laptop is having issues since downloading the KIES. I think factory resetting the phone is a dramatic move, nonetheless it is the only viable option. Have you removed the downloaded KIES off your system? If not, please do. If it is still buggy, try a system restore point before you downloaded the KIES (prior to doing this, if you have downloaded anything important you may want to save it on a USB key or external harddrive).

I've tried doing that and I can't seem to go back far enough...


Also, in regards to Froyo you cannot downgrade your firmware to what it once was (Enclair 2.1). You need to wait for an upgrade actually. Until then, a factory reset will help to eradicate all traces of Eclair (2.1) so they don't conflict with your Froyo (2.2). This may help all the glitches or awkwardness that you may be experiencing; along with the buggy Calender.

I hope so...

I heard rumour that a new Kies is out. Maybe that will help too...
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones