• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Galaxy S3(Android 4.3 update) random "no service" and battery problems

Andarthiel

Lurker
Feb 14, 2011
9
0
Have an annoying problem with my S3 and it has to do with the 4.3 update as a quick Google Search reveals. Randomly it just loses all signal and gives me the "No Service" error especially when I activate mobile data. Also it drains the battery way quicker than what it used to. I've tried the solutions that have worked for some people like turning off account sync and removing Google Services app(which wasn't installed on my phone in the first place) but nothing worked. I realise that I can just go back to previous versions using ROMs and Clockword Mod etc but I got this phone with a plan and am still paying it off so I don't want to break any warranties with my phone company. Anyone got any solutions that can fix it without ROMs?
 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones