• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Galaxy S3 i747 Will not read sandisk SD Card and will not Format the card Please Help

ashcakes

Lurker
Mar 14, 2013
2
0
Ok So I have a Galaxy S3 i747 and it is rooted and on aosp_d2att_jb_milestone-1 android Version 4.1.2 and Baseband i747uCLEM

My Problem is that I have had 2 different SD cards on generic and the other a SanDisk Ultra 64 GB micro SDXC Class 10 UHS-1 Memory Card and no matter what I format it to it will not work my phone says that is it damaged when the card is formatted to exfat and FAT32 and it will not read it and give me the option to format the card ( but never formats it there is no option to on my phone)
the phone will recognize it when it is formatted to NTFS but it will not let me move it or download anything on to the card it gives me an error or says permission denied, and then i try to format it in this state but it will not pop up the option to do so anywhere in the phone.
hope some one can please help me to get my 64gb Sd card to workI have been searching for an answer all over the internet and tried everything and nothing has worked and all the reviews on amazon show that the card works on there Galaxy s3 devices.


 

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones