• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help gallery crashing and ATP not working


Mar 17, 2012
I'm lost, I've done some searching, tried a few tricks, and nothing's worked...so I'm creating this. It started earlier today after having an image saving to my gallery crash; the app got stuck in a never ending cycle trying to save the image...the phone went to sleep and when I woke it up the spinning circle was gone, the image didn't save, and now my gallery won't open.

Now, under normal circumstances, I would probably just hash it up as a weird thing, back my phone up, and wipe the damn thing...

buuuuuut, I don't have an SD card (sadly rely only on the internal storage)

aaaaand, Android File Transfer isn't working, it's constantly telling me that it can't locate my storage device.

Are these two problems somehow connected? the only way I can view a filetree is through the "Files" app on the phone. and that doesn't help me too much. Can anyone help me troubleshoot this.... realistically I only need to figure out a way to backup all my stuff on the phone (I know I know, shame on me for never backing it up to begin with). Because once everything's backed up, if nothing else works troubleshooting wise, I can always wipe the phone and start anew.

It may also be worth noting that under "Running Processes" - "Media" is in a permanent state of "Restarting" instead of showing a runtime.

Got a Motorola Droid Razr HD MAXX, Verizon, and using a macbook running 10.6.8 OSX. Am currently unrooted as well
Yeah disconnected. Was using snapseed to edit a photo, got hung up on the save. after many hours of backing things up to an old microsd i somehow got the gallery working again...then later that night I was saving photos from my VSCO gallery and the same thing happened.

am running 4.1.2 - 9.18.94 xt296 stock. no unlock and root for me :( i think i might just do a factory reset but i can't seem to move these VSCO pictures off the phone. they're not coming up anywhere in the device's storage
Upvote 0
Okay! So I factory reset, re-downloaded all my applications, and moved all my pictures but one folder back onto the phone. Everything was gravy until it wasn't gravy anymore. Pics are still failing saving across a few apps (I removed VSCO after it seemed like it was causing more problems). It seems like anytime an app hangs or can't quite do what it wants with a move or a save and everything bugs out. I had a few more gallery crashes (I was able to remove various offending files using Astro File Manager instead of the native file manager.) When I had to remove VSCO it (or something else) managed to deliver one more blow, and now the Android File Transfer just doesn't work. It more often than not opens when the device is connected but any attempt to copy anything over the cable causes it to freeze and crash (this is with debugging enabled AND disabled)

On top of all this the old VSCO photos that I was able to get off the phantom folder finally also won't show up in my gallery. (they were the last batch of pics to be moved back onto the phone, but their folder won't show up in the gallery).... Other pics show up in the gallery, when I plug my SDcard in it reads all the pictures on there (except for the photos from the VSCO app). this folder shows up in the Astro File tree, and can even be opened from there to the gallery...but they still don't show up in the gallery.

I'm finding this problem to be a little hard to describe due to its randomness. Hopefully I've put something useful here. I hate stock phones =( nothing but problems
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.