• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

GT-P5210 Won't boot, looking for recovery options


May 13, 2016
Had a Lady bring me a Samsung Tab 3 10.1 that doesn't want to power on, when plugged in it shows the battery symbol with the spinning circle. If you start the tablet it only goes as far as the Samsung Galaxy Tab 3 screen and just sits there for a long time till it turns itself.

Samsung Galaxy Tab 3 10.1 GT-P5210 SNRF2DB0F8LFW

I am able to get into the recovery menu.
I have already tried wipe data/factory reset.
I've tried using Kies 3, it attempts to connect to the tablet but never does.(Already run the connection troubleshooter)
I downloaded the firmware for it (from here: http://www.sammobile.com/firmwares/database/GT-P5210/XAC/), copied it onto a microSD card and attempted the update from external. It goes to Verify the file type of MD5, Before Install /sdcard.... --Install /sdcard. Sits there for about a minute, goes black, android logo with no command, and then back to the Android System Recovery <3e>.

Now my end goal for this is to get this back to factory, so I believe if I've understood things correctly means rooting is out of the question because you don't get access to the Play Store anymore (Please correct me if I'm wrong).

Let me know what you think, maybe there is a different firmware or file I should be using, or different recovery method I haven't tried yet.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.