• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Headache with Razr HD // need help.

Artiz514

Lurker
Jul 23, 2013
3
0
Hello everyone, I know I am new on this forum but I'm in desperate need of help, I think I came with a real problem.

I am currently using the Motorola Razr HD by Fido Canada, known as the XT925. Phone hasn't been rooted & didn't unlock bootloader. It's running latest Jelly Bean (been doing so for a while)

Been using it for about 6months or so, two days ago I take pictures and videos with it, everything working fine, next morning I put it on charge it close and start to boot ... over and over again. Been bootlooping the red M for a few hours. When I take it off the charger (wall plugged, original Moto accessories) the phone is working. But the battery would only go up to 11%.

I tried the soft reset, didn't work, AP fastboot, didn't work, wipe system cache, didn't work, hard reset, didn't work ... no cards in the phone, it's BLANK and I still get this error. I don't know what to do, is there anything I'm missing or the battery just went dead? Didn't do anything special with the phone and it bricked itself, whut tha?!?! Hope anybody can help me and save my day.. Thanks for reading, appreciated
 
Thanks a lot for the reply guys.

I decided to try anything I could think of before calling Fido / Moto, so I didn't yet but will shortly.
Unfortunately whenever I plug the phone it's still bootlooping, if I take it off the wall plug I can use it but only up to 11%. Highly doubt I'm still under warranty but willing to pay (depending on price obviously) to get it fixed.

Only thing I can think of right now is ; dead charger or dead battery?
Charger won't even show up on USB port, I don't know if it's a computer / phone or charger issue (I'd prefer a broke charger but ehh)

So I'm going to call Fido / Moto, problem is it's not really working out with my current schedule. AP Fastboot telling me battery is ok. I didn't do anything special with the phone before the issue, now that I think about it it might be related to the update.

Anyway, if I'm not under warranty at moment, I'd be tempted to try a flashing (if I can get battery up enough) if not .. feeling like I'm gonna have to get the battery replaced :(

(white flashing LED when plugged, dead battery sign on Razr HD?)

Thanks for the help y'all I'm out for work, hopefully I can figure out how to get it fixed soon. Will let y'all know when I called Fido / Moto or if I get to fix this. Any of y'all got experience with Moto repair center?
 
Upvote 0
Anybody else think it might be related to the update, or it's officially a dead battery? What I don't get is ... phone will still open and bootloop, so battery can't be FULLY dead. And phone won't bootloop when unplugged, it just boot up as it should do. Going to call Fido tomorrow to get some info about my warranty, if it doesn't work I guess I won't have choice but to get it replaced. :(


EDIT ; WHENEVER I CHECK FOR SYSTEM UPDATES I GET THIS MESSAGE ;

Check for update is not avaible at this time. Try again later.

What's up with that? ;/
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones