• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help with GrooveIP TCP/UDP Ports !!! (Pulling hair out!)


Dec 30, 2012
So here's the quick about me so you folks don't think I'm a complete idiot.

I've been a computer geek since the days before most folks heard the word internet. I'm not super programmer but I do know my way around.

Bought my wife a Samsung Galaxy Player 5.0 (android). She's learning how to use it and I've run into a wall with the google voice.

The Galaxy Player (glorified MP3 player) can apparently make phone calls using Google Voice and GrooveIP.

I have a firewall on our DSL internet. If I turn the firewall off, the unit makes and receives calls just fine. Sound is good, lag (latency) is almost not detectable and everything works.

However, when I turn the firewall back on, it doesn't work properly. The android can make a call but neither party can hear anything. When someone tries to call the android, the person calling hears it ring but never gets connected but the android does ring and when you pick up, there is just nothing. (again, to the person calling the android, it just keeps ringing)

I have researched and researched. I activated port forwarding for all the TCP and UDP ports I could find references to.
TCP 5222
TCP 19294
UDP 19295
UDP 19302
I also set the grooveIP app to use 2 ports starting at 19000 and I made sure to port forward UDP 19000, 19001, 19002. I also found references to 19003 and 19004 for an older app so I forwarded those also.

I have a Playstation 3 and Call Of Duty that also requires a dozen port tiggers to be set up and I was able to do that on the first try.

Nothing I have tried is working.

Any suggestions????
Setting the android to DMZ seems to have worked but not without glitches.

All is well when the android calls out..
When someone calls in to the android, it will only connect if you wait for it to ring a full three times. Ya.. you have to count, 1 ring, 2 ring, 3 ring, then push the answer button. If you answer it before the 3rd ring, the call doesn't connect and to the person calling in, it just keeps ringing.

I did try to answer the call on the first ring, bring up the dial pad and push 1 but that didn't work.

Also, I absolutely hate having this thing on open to the world on the DMZ.. Seems like that's just asking for trouble.

As for the play station and plug-and-play, not sure what you mean but I had to manually configure each and every port to get the PS3 and Call of duty to work.. doesn't seem very plug and play to me.

Also, some free advice: NEVER LET ANYONE STICK YOU WITH A WESTELL MODEM. I have a westell and it is a piece of crap.. If you ever get internet and they want to give you a westell, tell them absolutely not! This thing has zero support, zero useful documentation and is slow as molasses to configure. WESTELL MODEMS SUCK
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.