• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Home wifi issues


Apr 14, 2012
I've had a 4G touch for about 8 days and have not been able to use my home wifi network. The phone shows that I am connected to my home wifi but when I try to download content the app just clocks and eventually times out with an error message like "not connected".

The 3G network works fine. Everything else works fine except my home wifi. On the phone - in Settings | Wireless and network | Wi-Fi settings under Wi-Fi settings in Wi-Fi I see "connected to mywifi" and under Wi-Fi networks mywifi network is displayed and it says "Connected".

Here are the steps I've tried:
-Called Sprint tech support. Recommended I try connecting to a public wifi or the wifi at my local Sprint store.
-Was able to connect to a public wifi
-Was able to connect to the Sprint store wifi.
-Called Sprint tech support again but they will not help since I can connect to other wifi networks.
-Returned to Sprint store and they reset the phone (volume up button and power button simultaneously).
-Still not able to connect to home wifi.
-Returned to Sprint store and replaced the device with a new phone, same model.
-Still not able to connec to home wifi.

Here is my home setup:
-Linksys E3200 router.
-SSID broadcast disabled, WPA2/WPA Mixed security
-MAC wireless filter enabled
-Router address:
-Max users: 50
-Static DNS set
-Channel width/channel: auto
-Guest access account available

I have 2 laptops, nook tablet, 2 ipod touch's, 1 iphone, and a wii all working with my home wifi network - no issues.

Here is what I've tried at home:
-Power cycled cable modem and router
-Rebooted router using router web page
-Enabled SSID broadcast
-Disabled MAC filtering
-Tried connecting to guest account

Nothing worked. If you have any ideas on what else I try it would be greatly appreciated. Please - don't make me get an iPhone!
Yes - still have stock software. Current firmware version is 1.0.01 build 3 Apr 21, 2011. There is a new firmware version.Do you recommend upgrading?

If he doesn't, I certainly do. :) Update the firmware and make sure you are getting the pw set right on your phone. Once you've updated the firmware, clear the connection on your phone and set it up again as a new connection. If that doesn't work, the you're probably S.O.L.. Also, I have no problems what-so-ever with my home wi-fi (or any wi-fi for that matter) playing nice with my totally stock E4GT.

EDIT: I don't know why Linksys would put out a firmware update, and then tell no one to install it. But since they do, maybe do not update it. Double check your pw settings on the phone and make sure it is correct for your network. I'd still probaly update the FW on the router, but that's just me. ;)
Upvote 0
Try clearing it and setting it back up. Go menu>settings>wireless and network>wi-fi settings>click on your network then choose forget. Then back out and go menu>settings>wireless and network>wi-fi settings, scan for yours and then choose it and set it back up with your network password. Make sure your pw is correct because if it's wrong, you can still connect, but it will have no connectivity.
Upvote 0
It had nothing to do with the phone, router or sprint. The problem was the openDNS DNS servers I had configured in my router. For some reason the phone could not find those servers. We configured the router to use the mediacom DNS server and viola! it worked. All is good.
To continue to use the openDNS DNS servers in my home network and use wifi on my phone would be to specify a static IP on my phone and specific non-openDNS DNS servers (e.g. google or mediacom's DNS servers).
I think this is an issue with openDNS and I will be contacting them.
Thanks all for your feedback.
Upvote 0
I'm having this same problem currently as well. I use a 2wire router/gateway from ATT, but i'm not up on my tech-speak enough to pretend to understand what was said in this thread. I can connect to other networks, and my phone shows that it is connect to the home wifi, but i can't do anything with it at all. Can someone explain to me what to do about it in layman's terms? I'm guessing this would also be why i can't access my shared folders on my Vista-equipped laptop as well?
Upvote 0
My linksys router has a section where you can specify static DNS. These are servers that translate Google to an actual ip address, like If your device can't talk to a DNS server, it will never find any web sites or other locations on the internet. For whatever reason, my phone could not find the DNS servers specified in my router configuration. When I specified different DNS servers, my phone started working.
I would recommend calling tech support for your home router or find your favorite local computer geek who might be able to help you. I was lucky enough to a neighbor that works for Cisco who helped me figure it out. Good luck!
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.