• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

New Android 11 phone, "Limited connection" WIFI


Jan 25, 2017
I just bought a TCL Alcatel A3 Tracfone, running Android 11, to replace the A2 I bought last year, running Android 10. I have not yet activated the service (current service does not end until 2/2023) but have been trying to go to the Play Store to add some apps, using my home WIFI router, which works fine with the A2 & every other device I have ever connected to it. For some reason, while the A3 "connects" it says "Limited Connection", and basically won't connect to anything, including Play Store. The A2 goes there & elsewhere, no problem. Driving me NUTS! What could the issue be?

Are you having the same problem when connected to a different WiFi network elsewhere? (i.e. a friend or neighbor, or at work)

If your TCL A3 only has a problem with your home WiFi that indicates there's some issue with your router. If you're having the same problem with any WiFi network, that indicates the problem is with your phone.

-- If it is your router, apparently your TCL A3 only supports 802.11b/g/n so this is conditional but if you have a newer router and you set it up to use only 802.11 ac, the newer protocol, you should set it to also support 802.11n. (But most routers by default are set to already be backwards compatible).
If that's not an issue, try setting up a guest WiFi network, using just its default settings, and try to connect your TCL to that temp guest network.

-- If the issue is with your phone, try looking through your Settings menu for something like a 'Network Settings Reset'. Keep in mind that's going to reset all network related settings back to their defaults so it pertains to WiFi, cellular, and Bluetooth.
  • Like
Reactions: ocnbrze
Upvote 0
Thanks for the replies. I've tried rebooting a couple times, no difference. I just tried resetting network & all else, no difference. The router is an older N150 Netgear WNR1000v2, but again all other devices connect fine. At this point I'm going to go over to the public library tomorrow & see if it connects there & if not try it on the work wifi, if still nogo I'll probably return it. Been using Tracfone for about 15 years, have had scores of them, never this issue, though I'm not positive I ever tried going to wifi before activating the Tracfone calling account. That shouldn't matter, I would think.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.