• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

ID3 tags not read properly (year: 0)


Apr 12, 2013
My phone can find all my music, but a lot of the album tags show as <unknown> even though I know these tags are filled in. Also, almost all of the 'year' ID3 tags are filled in as '0' when I know every file has the correct year filled in.

I don't know why my phone read the files this way. I have a 128gb SD card, formatted FAT32, and this is where I keep my music. What can I do to get my ID3 metadata reading properly?
Not to hijack your thread, but I have a similar problem that I have been trying to fix for a few days now. I figure I would share everything I have tried so far and maybe bounce a few new ideas around.

My situation is like this. I have a Motorola Moto G4 running Nougat 7.0. One night, I happened to be looking for a particular song by a particular artist, but the whole album was missing from their listing.

It turns out it was categorized under unknown artist. Not only that, but there were about 20 other albums there as well. Upon closer inspection, there wasn't any data associated with the files. For some reason, the media player wasn't reading the ID3 tags. It was pulling the folder name and the file name, but that was it.

First thing I tried was wiping the cache of the different music players I have been using. I have been trying out a few to see what I like. They are Google Play Music, Shuttle, Pulsar, and Phonograph. No luck there.

After a quick Google search, it seems like this is a common problem with no straight forward answer. Thr next suggestion I found was to wipe the Media Storage data and cache, so I tried that and after waiting for the library to rebuild, the files were still unknown. There were actually even more random files there now.

So since all of my music is on a 64GB Sandisk SD card, I decide to check if it is corrupted. I plug it into my PC and run chkdsk on it and it is fine. Looking at the MP3 on the computer, I can see all of the tag info there. I use Tagscanner to tag all of my music, add cover art, and sometimes lyrics and stuff.

So next I decide to check my backup MP3s on my PC for corruption using MP3diag. Some of the files come up with errors like truncated data stream or null frames and things, but a majority come back fine. I used MP3diag to repair any problem files and decided to use one album to see if the phone could read it.

So after another cache wipe, I copy the files to the SDcard, insert it into the phone, and power it backup. I waited for the media library to rebuild, and when I checked back later, still no luck.

Next thing I try is moving the folder yo internal storage. Cache wipe, reboot, library rebuilds. Still nothing.

Now I'm getting desperate. I tried renaming the folders. Nothing. Renaming the files. Nope. So now I download and app called ID3fixer. It claims to fix the tags of the MP3s. When I run it on these files, I noticed something strange. It can actually read the ID3 data off of my files. I know it's my tags because I had lyrics on the songs and it showed them.

So the app gives 2 options for repair. The recommended option is to repair the file directly, so that is what I try first. Repair, wipe cache, reboot, rebuild, and nothing. Damn. So I try the second option which is to repair the Android database and what do you know, that works... sort of. The tags for artist and album show up, so it is in the right spot in the media player now, but it is still missing some data like track duration, which comes up 0:00, and track number.

Next, I put the SDcard back in my PC. I make new copies of my PC backups, and remove the ID3 tags completely from the files using MP3tag. Put them back on the SDcard and that back in the phone. Now it can read the files and track duration, but since there is no ID3 data, it pulls the album info from the folder name and track name from the file name.

So I take the SDcard, put it back in the PC and tag these new files using MP3tag to auto fill the info from the web, but when I put the card back in the phone, they still come up unknown and the track duration is missing again.

Now there is something curious. The Phonograph app is the only media player I have out of the group that allows tag editing. When I use it to edit these problem files, it can read the current ID3 info that's already on the file. Another thing is if I use the same app to pull up the song info for a file, it shows all of the right info, even track duration, even though it show 0:00 <unknown artist> while it's playing.

Again, before anyone asks, I unmount the SDcard when removing it from the phone and PC. I have done multiple wipes of the Media Storage data/cache, as well as wiping the app data and cache.


I have tried to wipe the cache and many other things with no results. My conclusion is that there's something about the files that Android is storing that doesn't get wiped, or possibly I'm not wiping everything that matters. I did find a system app called External Storage, but I'm hesitant to wipe it because I couldn't find any info on what it does. I still won't rule out the files being corrupted, but I don't think that's it.
Upvote 0
It sounds like we're having the same problem. I'm also running nougat. My SD card is a Samsung 128GB. It's also formatted at Fat32, for what it's worth. I wonder how yours is formatted. I doubt it matters if they are wrong in the internal memory.

And like you said, my year tags are clearly there when I use a desktop application to inspect them. The mp3s were tagged in linux, for what it's worth. I don't think that makes a difference.

I have tried id3 fixer, to repair some mp3s, and just repair their entry into the music database. But this doesn't fix the problem.

The only other thing I can think is that it's a permissions issue. However, when I view files over ssh, my mp3s are owned by user '1' and have 777 permissions -- which is the same as my photos, which were taken by the device. So I don't think it's a permissions issue.
Upvote 0
I'm using BlackPlayer, and the other poster here mentioned Phonograph and some other players. So neither of us are using the stock Moto player, which is just Google Play Music.

However, Android seems to use a central music and playlists database that other apps read from, and this seems to be where the problem is. BlackPlayer has a debugging feature where you can read tags from an mp3 directly, and when I do this, I can see that all the tags are in place. But if I use the normal browsing feature, tags are missing, and the same tags are missing no matter what other app I use: Google Play Music, GoneMad player, or any other.
Upvote 0
Here is post back in April from another user having the same issue. Don't know if you've seen it already. They also have a Moto G4 running Nougat, and they come to pretty much the same conclusion.

They do mention something interesting. They split one album in 2 and gave one album a new name, and the new album was recognized. I'm not sure if they were talking about renaming the folder structure or the actual tags, but that's something I am going to mess around with next.

As for how my card is formatted, I can't recall off hand. I think it said some version of FAT when I ran chkdsk on it. I'll have to check later when I get a chance.
Upvote 0
My problem is solved! It turned out to be that the embedded artwork was too big. Not the actual dimensions, some of my artwork is over 2000x2000 pixels, but the file size of the artwork is what caused it. Most of the problem artwork was over 1MB. I couldn't find what an exact max size should be, but it seems even over 700kB might be too much.

Now, I don't know why it's an issue for Android's media scanner, but it shouldn't be. It doesn't even give an error code.

I ended up using GIMP to reduce the quality of the jpegs enough to get the file size down. If you need a program to see how big the file size of the artwork is, I used Tagscan.

Just replacing the artwork was enough to get the artist sorted right, but there were still issues with track number and album date for me. Fixing that required a wipe of the Media Storage apps data, and then a reboot of the phone.

Hopefully this will fix your problem, too.
Upvote 0
Interesting. Every broken MP3 had huge cover art. I replaced them all with smaller covers so we'll see if the tags get picked up properly.

I don't think this is going to fix the issue with years not getting read, because that's most files for me, even ones with small cover art files. But this definitely fixed the most broken files.
Upvote 0
Hey guys, I'm a little late to this party but I have a little more insight to this idiotic problem. I think the problem is Nougat. I use an HTC M9 running Nougat as my phone and I have an M8 running an older version of Android as my bathroom/gaming phone. My M8 has no problems with ID3 tags but my M9 has the same issue you guys are describing. I've renamed all the files and changed the artwork and still the same crap. Has anyone found a solution?
Upvote 0
It could definitely be a Nougat problem. This never happened on my Galaxy S3 running Kit Kat, and most of these mp3s came from that phone.

As for your problem, are you positive that the artwork you used had a file size under 1MB? Changing that fixed my problems. After that, the only suggestion I have is to clear the Media Storage app cache and reboot.
Upvote 0
There are probably easier ways of doing this, but here's what I did. One quick piece of info though. I keep all of my artwork embedded in each individual mp3 as opposed to one artwork file in the album folder. Not sure if that will make a difference. It's also a little hazy because it was a while ago, but this should give you an idea.

First, I opened the artwork file in GIMP. Any graphics program that allows you to compress the file should work, but GIMP is free, and I like free. If you need to pull the artwork from the mp3 first, Tagscan is the program I used for that.

Okay. So then, under File, I chose 'Export as...' and chose jpg as the file type, and the next or save or some other button. When it comes up with options for how to save it, I ticked the box for preview image. That will show the size of the new file it's exporting.

Next, I lowered the slider at the top until it came to a good size. I compared the size to file that were working, and turned out to be around 700kB or smaller.

Then, I used Tagscan to embed the new artwork, put the mp3s back on the phone, wiped the media storage cache, rebooted, and let the cache rebuild.

Whew. Hope that is clear for you and that it can help.
Upvote 0
Hi, Thanks, been looking for a solution to this problem for a while, Moto G5, android 8.1.0 one folder of music kept becoming <unknown> for artist and genre after a while, tried everything, the artwork was only 16kb so not large, I removed all the embedded and loose artwork from files and this folder and it fixed it insantly, didn't even have to restart phone
Upvote 0
I still can't find a solution to this on any of my phones for the last 5 years or so. I've had LG phones until now...I now have a OnePlus 8. Any music player I used does the same thing. Many artists are listed as "unknown" and sometimes the song name is off as well. There just doesn't seem to be a good way to fix this. I've tried some tag editors and the music player I'm currently using has a built in tag editor, and each time the tags read correctly. When I connect the phone to Media Monkey on my laptop, the tags are fine. I even tried transferring directly from Media Monkey since tags are perfect there. Still an issue. FRUSTRATING!!!
Upvote 0
I still can't find a solution to this on any of my phones for the last 5 years or so. I've had LG phones until now...I now have a OnePlus 8. Any music player I used does the same thing. Many artists are listed as "unknown" and sometimes the song name is off as well. There just doesn't seem to be a good way to fix this. I've tried some tag editors and the music player I'm currently using has a built in tag editor, and each time the tags read correctly. When I connect the phone to Media Monkey on my laptop, the tags are fine. I even tried transferring directly from Media Monkey since tags are perfect there. Still an issue. FRUSTRATING!!!

Did you try any of the solutions discussed in this thread, like the most common issue seems to be album artwork is too large. Which has actually been a problem for some mobile and portable MP3 players, even before Android. If the album artwork embedded in an MP3 is too large, like above 1MB, some players just choke in it.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.