• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Inaccessible MicroSD Card on Memopad 8 (ME181c)


Dec 30, 2014
Hi there,

I have an Asus Memopad 8 (ME181c) which has been successfully rooted the the point I can use Super SU and runapps like Root Explorer.

I have a MicroSD card (SanDisk Ultra, 32GB) which has been properly formatted to the best of my knowledge. The contents of the SD card may be successfully navigated using root explorer (and root-granted apps) and are located at:

This strikes me as odd, since on my Galaxy S4 the contents sit under "/mnt/extsdcard" or some similar, much simpler and less convoluted file path.

Root explorer and apps which have root access are able to access the files, however the default file manager (and the file browsers of non-rooted apps such as my emulators and comic book reader) cannot find the files. Non-root granted apps can locate this folder:


...but it is empty, and does not contain the "MicroSD" folder for non-root granted apps. Any folders and files contained therewithin also seem to be inaccessible.

If I copy any files or folders to the level of the file structure which is at least visible to non root-granted apps("media_rw"), those folders and files remain invisible to non-root granted apps. Sometimes I am prompted to re-mount with different read/write permissions, accepting this directive does not alleviate the issue.

  • If I try to launch a comic file or a rom from the root file browser, nothing happens. The emulator or comic reader fail to load, or fail to load the file
  • I have tried editing my permissions.xml in order to bypass KitKat's ridiculous inaccessible external memory shenanigans, no dice
  • I have tried using a bespoke app (or several) to achieve the above, all of which require and are granted root access - still no dice!
  • I have tried formatting and re-formatting the MicroSD, I don't think it's the hardware that's the problem though
  • When I swipe down from the top of my Memopad's screen to access the notifications menu, it successfully displays that the external storagte is mounted. When I tap "open" - nothing happens
  • The device is capable of seeing (accurately) how much data on the MicroSD has been used

Any help would be awesome, thanks!

- ~ Waru


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.