• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Multiple apps stuck on loading when entering account details


May 14, 2023
I have a Samsung Galaxy A11 running Android 12, nearly 3 years old.

A while ago I installed an app (rova, a New Zealand radio app). It got me to register with email, etc, and all worked fine. However, several months later the app began acting up; e.g. being stuck showing a loading indicator on the opening screen. Clearing the apps data and trying again allowed it to load straight away, but then the app kept hanging during the sign in/registration steps. I would try reregistering; enter my email, push submit, indefinite pause with loading spinner. Close app, reopen, this time get past email but fill in some more fields, indefinite pause. The app wouldn't hang as such - I could press the back button to go back a step - just show loading and not move on. Eventually I figured out that if I leave it for around 10-15 minutes it would progress and I'd finally get in to use it. But the next day, same thing. I put it down to a buggy app and moved on.

Yesterday I installed a different app (Tend, another NZ app for healthcare) and have been experiencing identical issues - enter email; loading... quit, try again, get past that to enter a phone number, loading... quit, try again, app stuck on intro screen... etc.

It feels like the phone is hanging reading or writing from storage as clearing the app's cache/data always lets me straight in again, but I haven't been able to get through the entire registration process.

I have tried clearing My Files data, removing unused apps (plenty of storage space available), reinstalling the app(s), rebooting the phone, and lastly wiping the cache partition.

Does anyone have any suggestions? I am a web developer - no knowledge of Android at all, but in the sense that when there is an issue I like to debug it, but I have no idea how to even find out what the phone is trying to do while it's loading.

Factory reset is of course a last resort but I'm hoping there are other steps to try first..
Since you're having issues with more than one app in particular, perhaps you need to redirect your blame on each app as it fails to be able to authenticate itself to its respective online service and instead start looking elsewhere.
Is this occurring only when using WiFi or only mobile data (cellular)?
If the former, have you tried just restarting your router, or tried connecting to a different WiFi network? If things work out OK that would point to a problem being just a glitch in connectivity, not the apps themselves.
If the latter, are you able to send/receive phone calls and text messages OK? If those are also problematic that indicates the problem is with your cellular service. Try rebooting your phone (assuming you haven't already as that is the de facto thing to always try first when something that's been working fine previously but just started to be problem), or try re-seating your SIM card.
-- If this authentication problem is occurring when using both WiFi and mobile data, than start looking into the basic networking service in your phone itself, the point being if one app starts to have a problem that does indicate it's that app in question but when more apps and services start having a similar problem the odds each one of them are also coincidentally failing at the same time is unlikely.
Upvote 0
I've tried on both wifi and mobile data and the issue occurs on both.

I agree it's unlikely to be issues on two apps independently, but everything else on the phone appears to work fine - calls, messenger, Google Maps, Facebook, and all web browsing in Chrome. The radio app, when I did get through the sign-in/sign-up when I last tried months ago (had to basically wait 10 minutes on each screen and come back to my phone later and it would have progressed), also broadcast fine after logging in - in all cases it seemed to be just the form submissions (including when it probably tries to auto-input my saved information and log in automatically) that fail.

Is there any way to monitor the requests it's making so I can see if something is timing out/etc, like I would do on a computer via F12?

Edit - sorry, forgot to reply to the other message. No SD card; 11.1 GB available (out of 32 total).
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.