• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

MXQ OTT TV BOX

Please help. This is a brand new box just arrived today. After plugging in it booted to the launch screen at which point I realised the remote control would not work. After trying different batteries I went next door to my neighbour who has the same box. My remote magically worked on his box but his did not work on mine. I tried resetting the box again but no joy.The box seems to be stuck in the on position. Upon switching it on the red light immediately goes blue and then is completely unresponsive. I have no mouse to plug in but the fact no remote will communicate with the box suggests there is a problem. Is this familiar to anyone? Does anybody have any ideas whatsoever what is going on before I schedule a return? Thanks in advance.
 
U will need a usb mouse but you can try going to setting advance and turn remote to on. Unplugging and letting sit for a minute might work. There have been problems posted online about remotes not working after certan firmware installed. Might have to reflash firmware. There is also a reset button in the av hole on the back of the box that will set box back to default setting.
 
Upvote 0
OK I will try a mouse tomorrow however I don't want to use it forever obviously I can't access any of the settings at the minute as I can't launch the box.

My next question is:

1) If I put a pin in the Av what effect will that have on the box?

2) If I use the mouse to get in will changing the settings enable the box to turn on/off and the remote to work?

If not then I want a new box instead of persisting with this one. I don't want a box that's permanently on.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones