• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help My alcatel phone wont boot up properly


Jun 2, 2021
Hey! My phone wasnt responding to touch, so i shut it off, expecting it to reboot normally. When i tried to turn it back on, it either:
-Got stuck on the loading screen
-Turned on and got to the loading screen, then turned off
-Wouldnt turn on at all

I was able to access the factory reset menu, but with every single option (aside from reboot or power off) comes up with the result 'E:failed to mount /cache (Invalid argument)' repeatedly. This happens for every single option, including factory reset, which im fine with doing because i didnt have too much stuff on the phone.

Ive attempted this twice now, and after i reboot the phone it gets stuck in the same loops as above. I removed the SD card and tried it, that didnt help much either. I dont wanna lose this phone as i need my CAR GROOVES . i gotta JAM. anybody have experience with this issue? please help !
Last edited:


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.