• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Obtaining IP address problem

Max_Headroom

Well-Known Member
Jul 24, 2011
178
13
South Cumbria - England
I have had a nightmare at work trying to use the open wi-fi supplied to customer, every time i tried to connect i got the Obtaining IP address message and it would not connect.

I tried all the usual stuff and nothing worked even though workmates could connect with no problem, after much searching i eventually found this solution having tried many of the ones that didn't work that i found using google.

I haven't a clue how it works but it does. (if someone could explain i would appreciate it)

The solution is to use a static IP for your WiFi connection, to do this:

Go to Settings >

Wi-Fi >

press on your connection for a second, a pop up will appear with the options "forget network" and "modify net configuration" >

select - modify net configuration >

select - show advanced options >

minimise the keyboard >

select - IP settings >

Select - Static

Now enter the settings below (make a note of the ones already there in case you want to change back)

IP - 192.168.1.253 or 195.168.1.253

Gateway - 195.168.1.1

NPL - 24

Netmask - 255.255.255.0

DNS 1 - 8.8.4.4 or 8.8.8.8

DNS 2 - 4.4.4.4

And save.

Press the Home button and now try to connect.

There is another solution that didn't work for me but has worked for a lot of people and that is to try to use the Allshare play app, apparently when it loads it asks you which network you want to use and clicking on yours makes the phone work on your network again.
 
  • Like
Reactions: erikab922
If it were remotely appropriate I would kiss you! We changed broadband suppliers today and I've been trying to get my S3 to connect to home WiFi since 10am and was this close to wanging the phone out the window.

The only issue I now have is that every time it re-scans for WiFi the connection drops and then re-connects straight away so it's like on-off-on-off. But it's a step in the right direction!

EDIT: Hmmm, not working any more, getting DNS issues. I love the S3 but I cannot get WiFi to work and this is going to be a deal-breaker I think.
 
Upvote 0
Unfortunately you cannot use it on, say, work. No option to use static IP.
Here is what worked for me:

Had the same: it works at home and other places but the work - so it must be something with work WiFi.

I went in WiFI settings (Settings\WiFi\Advanced\WiFi Frequency band) and noticed that WiFi band was set on Automatic - other options 5GHz, 2.4Ghz.

I set it to 2.4GHz and it started working fine, slower but it works!

I guess they have cheap routers here that cannot hold 5GHz

Try it
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones