• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Help Outgoing email only work with WiFi - Charter.net email - Samsung s3

I have configured my phone to use mobile.charter.net . While I can receive email, I can't send email unless I am connected to WIFI. I
spent 1.5 hours on the phone with Charter support. I was told that Charter Call Center only supported laptops . Mobile devices aren't
supported except for the information below c/p from Charter WebSite.
Does mobile charter email work for you without WiFi? If yes, what settings are you using and what email app? THANKS in Advance.
Note: gmail works. I can send/ receive email without WIFI enable.

Mobile Email Settings

Username: (Make sure you enter @charter.net after your username or you will be unable to login)
Password: The password you use to login to your email account
SSL: This setting should be on for both SMTP and IMAP
Protocol: IMAP
Incoming Email Server: mobile.charter.net
Port: 993
Outgoing Email Server: mobile.charter.net
Port: 587
Same issue here. I have 3 email accounts on my phone, gmail, hotmail, and work email. I only have this issue with my work email account which is a pop3 server. Weirdest thing - can receive email messages on on mobile network, but can't send. The other 2 accounts no issues. I use Sprint as provider.

If anyone can help would be much appreciated.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.