• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Phone keeps rebooting on Volume Up + Power (trying to install ROM)


Jan 5, 2021
I tried to install Android's ROM and got ERROR 7, then I wiped out cache, data, internal storage, where was twrp.apk installed.
After that I cant get into boot menu (with Install, Wipe... buttons).
Then I copied twrp to the phone:
sudo fastboot flash recovery <twrp.img>
Tried versions 3.2.1-0 and 3.4.0-0, because I heard for certain phone (I have Xiaomi Mi4) it's necessary to use proper version, though I don't know which.

What's going on now: I can successfully can get to the nice splash screen using Volume Down + Power, then on my PC I give sudo fastboot reboot command and press Volume Up + Power and here is the problem: It has no effect, it just keeps rebooting (I see only Xiaomi's logo).


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.