• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Pixel 5a carrying over an SSL cert issue from old phone. Please help


Mar 11, 2022
So a while ago I made a post about my old Moto G Play 2021 having data issues. When i was using mobile data rather then wifi, things that used SSL seemed to not work (visiting reddit on chrome would yield an ERR_CERT_AUTHORITY_INVALID error, and don't let me visit websites like that.) Stuff like youtube or discord wouldn't work, but spotify and googling shit worked somehow.
I had tried full factory resets, syncing the time, buying a new sim card, clearing cache and cookies, etc. I've genuinely never heard of anyone having an issue like this on the internet after so much searching.

I gave up, bought a Pixel 5a, and it worked for a bit, but as of this morning, the issue is happening again. I genuinely have no clue what I could do, first it only worked with 5G and now even that isn't stopping the issue. If anyone knows of anyone or anything that can fix this, please let me know. I genuinely have nothing left to go to at this point.
So what's your setup?
Are you using Chrome?
Are you using an ad blocker with a VPN?

just chrome. Still had the issue after a factory reset on the old one so I don't think it'd cause an issue. The main part that confuses me is that my pixel worked for about 2 weeks, then started having the issue on LTE, and now on 5G and all other data connections.
Upvote 0
This is like the symptoms of a man-in-the-middle attack. You're not using any kind of proxy or an ad-blocker that uses VPN methods are you? Something that might interfere with SSL certs?

I remember seeing reports of something like this about 5-6 years ago, with certain hotel WiFi networks like Premier Inn and Ibis hotels, and I did see it myself when staying at an Ibis hotel. I guess that must have been something wrong in their networks, that must have subsequently been fixed, as there's been no reports since.
Last edited:
Upvote 0
Just to confirm, you don't encounter this problem when using WiFi, it only happens with mobile data (cellular)?

Or do you indeed run into these SSL cert problems when using both WiFi and mobile data?

Also, it's not clear if you're having problems with just a web browser app (which browser app are you using?) or if this is problem is with different apps having the same connectivity issues.

If the problem happens only when using mobile data that indicates a cellular connectivity issue. If the problem happens with both WiFi and mobile data that indicates a general networking issue with your phone. If it's just happening with a web browser app that's likely to be just a problem that app, if with some apps have cert errors but some are OK than it goes back to a mobile data issue.
Please clarify.
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.