• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.


Brian Santoyo

Feb 26, 2016
So I rooted my SM-G503T1 (Samsung Galaxy Grand Prime from Metro PCS) and it worked perfectly. A month later I decided for some mysterious reason to turn off OEM unlocking. I wanted to reboot my phone some time later so i did. Booting up it said Custom Binary blocked by FRP Lock. I googled the issue and found that people got this fixed by flashing the stock rom. so i tried this. Whin the download finaly finished I booted my phone to download mode, plugged it into my computer, and flashed the md5 using odin. But it failed. My phone saying that FRP Lock was blocking it. Also in the process it soft bricked my phone. on the screen it says. "An error occured while updating the device software. Use the emergency recovery function in the smart switch PC software. So I did but idk my serial number. I dont have the original device box. So thats also scratched off. So to summarize. I have a soft bricked phone with frp lock on and i dont have the serial number. PLZZZ HELP MEEEE
I don't have your phone and got the links from helping others with same problem. Your best bet would be to create a account at XDA and ask in the threads I linked. A lot of folks working on the problem there.
Good luck.
ok well you helped a lot thanks. Without you my phone wouldnt be functional for shit. A million times thank you.
  • Like
Reactions: El Presidente
Upvote 0


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.