• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Problems with Fastboot that does not really connect to device

cyanosus88

Lurker
Feb 4, 2016
2
0
Hi,

I'm trying to install Cyanogenmod on my ASUS Transformer Pad, following this tutorial.

I successfully unlocked the device, but I'm failing to use fastboot.

Using the command adb reboot bootloader I can get into the bootloader.

Surprisingly, whenever I type fastboot devices, I see my device without any problem:
<some list of hexa symbols> fastboot

However, typing fastboot reboot-bootloader gives
rebooting into bootloader...
with nothing happening then (my terminal get stuck, even insensitive to CTR+C).

Trying to flash the device (using fastboot -i 0xb05 flash recovery your_recovery_image.img) gives nothing, until I reboot the tablet, which only then prints on my terminal:
sending 'recovery' (6930 KB)...
FAILED (command write failed (Bad file descriptor))
finished. total time: 0.000s



So there seems to be a problem of communication between fastboot and the device.

Do you have any idea of the cause?

Note that my PC is a virtual Ubuntu machine running (using VirtualBox) on a Macbook.
(I didn't do it directly on my Macbook because I'm very unfamiliar of anything technical using Mac, and was not even able to install fastboot on it…)

Thanks!
 
Hi,

So the problem is already solved: this did come from Virtualbox. I was manually mounting the tablet to the virtual machine everytime I needed it, but this was not enough apparently: I had to add to the auto-mount list ("USB filters") the tablet (under 3 different ids, including 1 for fastboot).
So problem solved.
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones