• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root RSDLite won't show device anymore!

myko14

Member
Nov 12, 2009
75
0
CoMo
I have a Defy with the cell provider Viero (a small midwest company). I got it rooted with SuperOneClick. I had 2nd init and CM7 on it. It worked well through a few reboots as I added ROM Manager and Titanium back on it. When I left the house I noticed that I had full phone signal but no data service. That's when the trouble began...

I tried restoring the stock system data from TB but that knocked out the reception all together. On the next reset I was back to stock recovery and a bootloop. So I used RSD Lite to flash astock sbf. It said it PASSED but when it tried reboot it went to a black screen. I read up and tried flashing several other sbfs but I only got SW version...

Now when I start RSD Lite (4.4, 4.9, 5.4 with drivers updated several times) it won't show a device connected. I have tried loading new sbfs and hit 'Start' anyway but nothing happens. When I unplug and plug it back in it will show the white light on the front but nothing else, not even a flash.

Any ideas?
 
I have tried the Macgyver battery trick on USB and finally got it to work. Again, I have the Viaero network. I flashed the Defy Plus sbf and was able to boot to MotoBlur (I'm not crazy about that but it is a phone that boots!). Now I am back to the point where I can make calls but get no data connection without Wifi. Any suggestions on how to get the Mobile network state connected?
 
Upvote 0
You're not using a foreign .sbf? Have you tried based band switcher app off the market to see if that gets back your data?

You didn't have APNdroid installed before you did all this? (i only ask because you can loose all APN settings if uninstall while data is not enabled - or reflashing?). Do you have any APNs listed in your settings?

Or is your network, just crap?
 
Upvote 0
i had the same problem, i connected to rsd lite and tried to flash the sbf file which i have already used successfully before. rsd lite never passed the flash but told me to manually reboot my phone which i did. it got stuck on the android logo. so i reconnected to rsd lite and flashed again, the same thing happened, no pass. it got stuck again so i downloaded another sbf file but rsd lite wouldnt recognise my phone this time.

the macgyver hack doesnt affect the connectivity only extends the battery life.

just read it again, how did you flash the defy plus rom and where did you find it. ive seen guides to flashing it but they are so long winded.

thanks
 
Upvote 0

BEST TECH IN 2023

We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.

Smartphones