• After 15+ years, we've made a big change: Android Forums is now Early Bird Club. Learn more here.

Root Samsung galaxy ace s5830 in boot loop and usb download doesn't work.


Jan 5, 2016
Hi, I have a Samsung Galaxy Ace s3850 which had a problem with the wifi connection. As described on many forums the solution is to root the phone and then enter a code into the phone. It is needed to reload the wifi driver and is explained here:

Needless to say driver loading was unsuccessful after rooting and entering various code combinations. The phone has always been low on space and having recently found how useful link2sd was as well as the possibility to have a custom rom which increases performance I tried this route.

On this page they describe how this could be done on my phone: http://www.ibtimes.co.in/install-an...m-to-samsung-galaxy-ace-s5830-tutorial-551133

I tried following the steps exactly, except that there was never an option to clear dalvic-cache (no advanced settings) on the phones recovery menu. Also, the phone needs the home+start combination to go into recovery, not volume(up)+home+start (which takes one to the quick download I think).

It seemed to go well except that on reboot it didn’t go out of the Samsung logo screen after about 20 minutes. I read that this is too long and thus took out the battery and restarted. This didn’t help and the loop continues.

I thus tried to restore the factory stock rom using odin but every time I set the phone to download mode (volume(down)+home+start) the yellow download text comes up but windows comes up with usb device not recognised. The usb drive worked well before this when I needed to upload the google apps and custom rom file to sdcard as required before upgrading to custom rom. I even tried kies software (also removed kies from tasks when trying odin again so as to not clash).

I also tried various other custom roms to see if this does the trick but every time I go into recovery mode I get the following screen text:

Android system recovery <3e> blablah….

Reboot system now.

Applying update from sdcard

Wipe data/factory reset

Wipe cache partition

Test redbend

…….Green icon……

-- Appling Muti-CSC –

E:failed to mount /system (Invalid argument)

When I select “wipe data/factory reset” I get:

-- Wiping data…

Formatting /data…

E:format_volume: rfs format failed on /dev/stl13

Formatting /cache…

E:format_volume: rfs format failed on /dev/stl14

Data wipe complete.

When I select “wipe cache partition” I get:

-- Wiping cache…

Formatting /cache…

E:format_volume: rfs format failed on /dev/stl14

Cache wipe complete.

Rebooting goes into the same logo loop screen.

Now I am stuck with a phone which I suppose could be called a tile (not brick, its too small for that J). Any help would be much appreciated.


We've been tracking upcoming products and ranking the best tech since 2007. Thanks for trusting our opinion: we get rewarded through affiliate links that earn us a commission and we invite you to learn more about us.